Ask Your Question
0

Columns added to AutoFilter table don't sort together with existing columns

asked 2021-02-22 05:07:37 +0100

wekesa gravatar image

I got rid of Microsoft Office subscription and decided to rough it learning LibreOffice.

I ran into a minor hiccup. There are several documents created in Excel that I constantly access. They contain sortable tables created via Insert > Table, and I realized that this is called AutoFilter in Calc. Everything is well and good until I try to append new columns to the existing table. Usually, Excel auto-formats new columns with the same sortable function, and they sort with the rest of the table. When I do this in Calc, the new columns appear to be disconnected with the original columns. What am I doing wrong here?

The workaround I found so far is to disable AutoFilter on original tab in Calc, select old table range, copy, paste to new tab, add new columns, select the new range in the new tab, enable AutoFilter on the newly-created table. What a pain! Can you please let me know if there is a better way of doing this?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2021-02-22 20:25:20 +0100

m.a.riosv gravatar image

Maybe the options Menu/Tools/Options/LibreOffice calc/General - Expand formatting/Expand references when new columns/rows are inserted, when the columns are added.

edit flag offensive delete link more

Comments

Another epic advice! Thank you!

wekesa gravatar imagewekesa ( 2021-02-22 20:59:20 +0100 )edit

While that usually works, it also tends to get in the way in cases one forgot about it.. YMMV.. toggling it on a case by case basis might be best.

erAck gravatar imageerAck ( 2021-02-25 16:00:22 +0100 )edit
0

answered 2021-02-22 14:09:22 +0100

erAck gravatar image

AutoFilter is just a functionality on cell ranges (one anonymous per sheet) or so called named database ranges. Those table ranges imported should show up as database ranges under Data -> Define Range...

If columns are added left or right of the original range then the database range definition may have to be adapted. Inserting columns within the range should adjust the database range automatically.

edit flag offensive delete link more

Comments

Thank you so much! Worked like a charm!

wekesa gravatar imagewekesa ( 2021-02-22 20:59:44 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-02-22 05:07:37 +0100

Seen: 23 times

Last updated: Feb 22