Ask Your Question
0

I can not see a record Macro under tools in calc.

asked 2021-02-22 18:13:01 +0100

weathea gravatar image

I am running a file what was originally in microsoft excel and need to use macros.

edit retag flag offensive close merge delete

Comments

2

Does Tools -> Options -> LibreOffice -> Advanced -> Option: [x] Enable macro recording (may be limited) fix your problem?

Opaque gravatar imageOpaque ( 2021-02-22 18:19:39 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-02-23 07:43:29 +0100

Zizi64 gravatar image

updated 2021-02-23 07:56:45 +0100

Check the Settings as Opaque wrote in the comments. Restart the software after adjusting the settings.

Note 1:

The Macro recorder has a very limited capability. And only the Writer and the Calc has macro recorder feature but the Draw, the Base applications has not. You must WRITE your macros instead of recording them - if you want to work with macros efficiently. You must study and use the API functions. API: Application programming Interface.

Note 2:

The Excel VBA and the StarBasic+LO API combo are not compatible, and they are very different. The LO can run SOME of Excel macros (by switching ON the compatibility options), but the Excel can not run ANY LibreOffice macros.

...

Tip:

Install one of the excellent object inspection tool: MRI or XrayTool:

Then you will able to list all of properties, methods and interfaces of the programming objects.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-02-22 18:13:01 +0100

Seen: 37 times

Last updated: Feb 23