Ask Your Question
0

drag cell to move contents not working in Calc

asked 2014-02-07 16:44:41 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

New to LO and was working on a spreadsheet. I entered a number in one cell and text in another. I tried to move the cells down several rows but the cursor is not showing the proper moving symbol for dragging. The only option showing is the cursor changing to a + sign which fills all the cells. I use Excel and Numbers on a Mac OSX 10.9 and have no problem moving and have been using spreadsheets for over 20 years. Any idea what I am doing wrong or any specific setting for this?

edit retag flag offensive close merge delete

Comments

1

I can't test on a Mac, but on Windows and Linux I find that if I click, drag and release to highlight a group of cells then click in the blue highlighted area, hold the click and drag then the highlighted cells are moved.

w_whalley gravatar imagew_whalley ( 2014-02-07 19:55:47 +0100 )edit

Like commenter cameleon below, on my Mac this does not work if selecting only one cell. Dragging one cell only results in selecting more cells; there seems to be no way to "select" only one cell for dragging.

cdort gravatar imagecdort ( 2014-04-16 19:20:26 +0100 )edit

To drag a single cell (on Windows and Linux) click in the cell and hold the button down, drag the cursor into an adjoining cell and back to the original cell, release the button. The cell stays selected, then click in the cell again, hold the button down and drag where you want.

w_whalley gravatar imagew_whalley ( 2014-04-16 21:18:22 +0100 )edit

w_whalley workaround works for me (Windows) as click and drag only works when cell(s) are highlighted. The bug / trick is to get one cell only highlighted!

jim109b gravatar imagejim109b ( 2014-07-31 11:16:24 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-06-27 10:44:57 +0100

sancho.s gravatar image

Operations for marking cells for drag-and-drop are slightly different for a single cell or a range. See http://ask.libreoffice.org/en/questio...

Cell/s ready for usual drag-and-drop are shown with a different background and border color (light blue).

Single cell

Do one of the following:

  1. Click, then Shift-click the cell.
  2. Pressing the mouse button, drag a range across several cells, do not release the mouse button, and then drag back to the first cell. Release the mouse button.

Multiple cells

Simply click and drag across the range.

edit flag offensive delete link more

Comments

I'm familiar with this functionality, but it's not working. When I click the light blue region and drag, the mouse moves as though I didn't left-click (and hold). I just installed libreoffice 5 on Archlinux.

lmat gravatar imagelmat ( 2015-08-27 17:08:41 +0100 )edit

Same here. ArchLinux with LO 5.0.1. When you left-click and hold, it does not move the cells, it acts as if you didn't click.

nottin gravatar imagenottin ( 2015-10-15 06:04:02 +0100 )edit
0

answered 2014-02-08 11:49:47 +0100

ROSt52 gravatar image

Could make a test on Mac wit LibO 4.0.2 all works normal.

Select area
Click into the area
Move the area
Drop the moved area

edit flag offensive delete link more

Comments

doesn't work for me, after clicking into the area, moving cursor expand the area instead of moving the cell. Bu if you select multiple cells instead of just one, then you will be able to move them by drag and drop. OpenOffice and Libreoffice have always work like this :-(

cameleon gravatar imagecameleon ( 2014-02-09 18:04:32 +0100 )edit
0

answered 2016-11-04 11:16:05 +0100

Yes, ROSt52, it works for several cells but the problem only when I want to drag only one cell. I also have this problem, hope I get a solution for that !!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-02-07 16:44:41 +0100

Seen: 5,351 times

Last updated: Nov 04 '16