Ask Your Question
0

Garbage at end of edited line in Writer [closed]

asked 2012-05-28 04:42:56 +0200

owlbrudder gravatar image

updated 2015-10-16 04:08:20 +0200

Alex Kemp gravatar image

When editing text, insertion or deletion often does not correctly refresh the display until I force a refresh (by scrolling the window, for example), or until what appears to be a built-in timer initiates a refresh after a number of seconds, which I have not been able to time. (The only timer I can identify is in Options/Load Save/General/Save AutoRecovery Information, which is set to 15 minutes).

Garbage remains on the affected line, to the right of the insertion/deletion point. Often, the remaining text is truncated so the first character of the spurious part is only partly displayed.

This bug was posted to Linux Questions and at least one other user, on a different platform, has noticed the same problem. See http://www.linuxquestions.org/questions/showthread.php?p=4679493#post4679493

I have also created a LibreOffice bug report at https://www.libreoffice.org/bugzilla/show_bug.cgi?id=49986

In Options/LibreOffice/View, I am using Hardware Acceleration and AntiAliasing - that is the way LibreOffice was configured at installation time and I have not changed anything.

Under Fedora 14, using Compiz, I had identical display refresh errors when editing an OpenOffice Writer document. The fix then was to edit the Compiz settings, to enable the module 'Workarounds'. I cannot find any equivalent option with my current system.

I do not have display rendering issues with any other application.

LibreOffice/About reports: LibreOffice 3.3.4 OOO330m19 (Build:401) Ver: 3.3.4.1-4.fc15

uname -a reports: Linux [machine id] 2.6.43.2-6.fc15.x86_64 #1 SMP Sat Apr 21 12:53:32 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Browser: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0

Hardware is a Lenovo T61. I am using the proprietary nVidia display driver.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 04:08:40.184363

1 Answer

Sort by » oldest newest most voted
1

answered 2012-05-28 20:04:25 +0200

luyu gravatar image

Until that bug is fixed try resolving the problem by turning off Tools → Options → LibreOffice → View → Use hardware acceleration.

edit flag offensive delete link more

Comments

1

Excellent! That seems to work perfectly. Thanks for the tip. I will update the bug report to indicate this workaround.

owlbrudder gravatar imageowlbrudder ( 2012-05-29 02:19:54 +0200 )edit

Current status of fdo#49986 is RESOLVED FIXED.

qubit gravatar imagequbit ( 2013-02-19 00:33:28 +0200 )edit

Question Tools

Stats

Asked: 2012-05-28 04:42:56 +0200

Seen: 270 times

Last updated: May 28 '12