Ask Your Question
0

Why is formatting persistent after being toggled off?

asked 2021-03-12 03:39:41 +0200

fish_speaker gravatar image

updated 2021-03-12 21:15:13 +0200

I've encountered some behaviour in Writer lately that has been driving me crazy. I frequently switch between bold, italic and unformatted text while taking notes in Writer. As of a couple of months ago, it unpredictably will not toggle text formatting off after the shortcut key is entered, but will instead persist. I also bound ctrl+, to set the default character style, and ctrl+. to switch to Source Text. These are exhibiting the same kind of behaviour. This does not seem to happen reliably, it seems random. When typing bold text, for example, when I toggle it off the icon on the toolbar visually changes but the formatting persists. I have tried uninstalling, deleting my user profile and starting fresh to no avail. I have also tried disabling autocorrect and whichever pertinent settings I could locate. Am I missing something?

Example:

[ctrl+b]Java[ctrl+b] is an object-oriented programming language.

is often...

[ctrl+b]Java[ctrl+b] is an object-oriented programming language.

Version: 7.1.1.2 / LibreOffice Community Build ID: 10(Build:2) CPU threads: 12; OS: Linux 5.11; UI render: default; VCL: gtk3 Locale: en-CA (en_US.UTF-8); UI: en-US 7.1.1-1 Calc: threaded

*note: This does not occur when using Writer in Windows with identical (as far as I can tell) settings.

edit retag flag offensive close merge delete

Comments

Haven't you by accident modified the respective style? Show the file anyway.

gabix gravatar imagegabix ( 2021-03-12 05:45:06 +0200 )edit

This is surely a bug but you should learn how to use styles. Styles may seem a burden on first thought for small documents but they give access to much more powerful, reliable and versatile formatting than direct formatting.

ajlittoz gravatar imageajlittoz ( 2021-04-13 08:09:53 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-04-13 07:48:31 +0200

Coburn gravatar image

updated 2021-04-13 07:52:23 +0200

I am experiencing the same behavior. It seems to be from an update about 2 weeks ago, about the first of April. I'm using LO 7.1.1.2 on Ubuntu Hirsute. Not only does the CTRL sequence not toggle formatting off, but clicking the icon has the same result, i.e. no result. It's like a button on an appliance that is broken and pops back up after you push it down.

The only way to get back to normal text that I have found is to keep typing a character or two, then manually select the text (e.g. punctuation-space) that you do not want bold or italic, etc., and toggle it off.

I want to change text from plain to bold i (oops it didn't toggle)

I want to change text from plain to bold inline (go ahead and keep typing)

I want to change text from plain to bold inline and back again. (select and revert the rest of the text)

Another workaround is to type all the text in normal style, and then go back and select the text you want changed and toggle it on.

I want to do this using keyboard shortcuts.

I want to do this using keyboard shortcuts.

edit flag offensive delete link more
0

answered 2021-04-13 08:13:48 +0200

It may be a desktop manager issue that listens to the Ctrl+ sequence, stilling "the focus" from LO when you type it. I experience that on Windows 10 with very specific applications (I can't use any shortcut at all in LO then).

But it does not explain the button issue.

I were you, I would downgrade and if it works fine (with a former version), then file a bug report.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-03-12 03:39:41 +0200

Seen: 75 times

Last updated: Apr 13