Ask Your Question
0

Error : the maximum number of rows has been exceeded [closed]

asked 2014-02-18 16:22:40 +0100

teo gravatar image

Hello, I need to import a csv file into a database. The file has 4990101 rows, but if I open it, Calc gives me this error: the maximum number of rows Has Been exceeded.

How can I do?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 11:14:23.585001

2 Answers

Sort by » oldest newest most voted
0

answered 2014-02-18 21:44:22 +0100

m.a.riosv gravatar image

The maximum rows in calc are 2^20 1048576. So I think in calc nothing usable.

The better/only option could be open CSV file in Base as if it was a database, doing queries to reduce/summarize the data and link it in calc.

edit flag offensive delete link more

Comments

Great! Thank you. But i have another problem: If I open the table i see the cell's value like this:

"V A L U E" with white space between letters, i think it's an error on encoding?

If i open the file with Notepad++ it show me the encoding is "UNIX UCS-2 Little Endian", but if i try to set "Database\property\character set" in UTF-8 or UTF-7 it doesn't work

teo gravatar imageteo ( 2014-02-19 08:40:17 +0100 )edit

I can't see that character set in the list for select in Base, If you are not going to update the data regularly, try changing the character set with notepad.

m.a.riosv gravatar imagem.a.riosv ( 2014-02-19 23:05:47 +0100 )edit
0

answered 2015-10-17 12:15:39 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This is not good news for data mining, I hope the product will be improved to include more rows. I am not sure about LibreOffice Base either.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-18 16:22:40 +0100

Seen: 2,974 times

Last updated: Feb 19 '14