Ask Your Question
2

PDF font embedding in LibreOffice 4.2 ? [closed]

asked 2014-02-18 22:49:09 +0200

Edmund Laugasson gravatar image

updated 2016-03-03 18:42:20 +0200

Alex Kemp gravatar image

Since LibreOffice 4.2 I do not see anymore opportunity to embed fonts when exporting into PDF - are they embed by default?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 18:42:31.519859

1 Answer

Sort by » oldest newest most voted
2

answered 2014-02-18 23:35:05 +0200

oweng gravatar image

updated 2014-09-14 15:00:02 +0200

The custom font embedding option is still there under File > Properties > Fonts tab[1] (same location as v4.1). It sounds like you may be referring to the option to embed the standard 14 PostScript fonts (File > Export as PDF... > General tab > General section > Embed standard fonts option). Quoting from the related change:

Always embed 14 standard Postscript fonts in PDF

Ealier version of PDF standard allowed for not embedding the so called standard PostScript fonts in the PDF files and all PDF readers had to include them or a "suitable substitute". This behaviour had many issues and is deprecated for 10 years now. The current version of PDF spec says:

Beginning with PDF 1.5, the special treatment given to the standard 14 fonts is deprecated. Conforming writers should represent all fonts using a complete font descriptor. For backwards capability, conforming readers shall still provide the special treatment identified for the standard 14 fonts.

This commits removes support for not embedding these fonts, and the, now redundant, option to embed them.

[1] Note that this location may change. Refer fdo#64357.

edit flag offensive delete link more

Comments

I don't see the "Embed standard fonts" option in LO 4.3. There's only "Embed OpenDocument File."

Cecilieaux gravatar imageCecilieaux ( 2014-10-10 23:47:28 +0200 )edit

@Cecilieaux, that option is under File > Export as PDF... and not the menu I indicated above. Please re-read my answer.

oweng gravatar imageoweng ( 2014-10-11 03:38:55 +0200 )edit

Ahhh .... File > Properties > Fonts. It worked! Thanks!

Cecilieaux gravatar imageCecilieaux ( 2014-10-11 17:56:05 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-02-18 22:49:09 +0200

Seen: 13,082 times

Last updated: Sep 14 '14