Ask Your Question
1

How to activate the German dictionary extension? [closed]

asked 2014-02-20 09:52:09 +0200

iGor gravatar image

updated 2015-08-24 17:25:30 +0200

Alex Kemp gravatar image

Hi,

On Linux I don't have that kind of problem, I mean with languages support, dictionnaries and spelling check. But I'm also working on Windows, Windows Seven to be exact, with LO 4.0.2. I've tested with Windows 8 and LO 4.2, and I have exactly the same problem.

I need to use the german spelling check. On the installation I have, I found the spelling check for french, english and spanish. So I went to install this extension : http://extensions.libreoffice.org/extension-center/german-de-de-frami-dictionaries/releases/2013.12.06

Once the extension is installed, I go to Tools / Options / Linguistic parameters / Linguistic and check for the language modules available : french, english, spanish. There's no german spelling ckeck. I tried to restart LO, to restart the computer.

I don't understand how to activate the german dictionnaries after having installed the extension. What am I doing wrong ?

Thanks for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-23 12:10:13.738203

2 Answers

Sort by » oldest newest most voted
0

answered 2014-02-20 15:04:43 +0200

manj_k gravatar image

updated 2014-02-20 15:11:05 +0200

Tools → Extension Manager...→ Add... → dict-de_de-frami_2013-12-06.oxt → Only for me
works well for me with LO v4.2.1.1/v4.1.5.3 (on Windows7) after a restart of LO.
(You have also to close quickstarter if enabled.)

Is the German (DE-frami) spelling, hyphenation, thesaurus 2013.12.06
enabled in Tools → Extension Manager... (without any error message)?

image description

As you can see in the screenshot above:
The current German frami dictionaries (Austria, Germany, Switzerland) are also available as bundled dictonaries in the LO 4.2.x Windows installer. You can enable these bundled dictionaries with a custom setup (Install → Modify) under Optional Components.

edit flag offensive delete link more

Comments

New link for Optional Components

manj_k gravatar imagemanj_k ( 2014-05-07 21:46:24 +0200 )edit

It's even weirder than that. I've uninstalled LibreOffice. And reinstalled it. But I've chosen the custom install and check the german dictionaries. And there are still not available in the linguistics options.

http://id-libre.org/bozon/index.php?f...

iGor gravatar imageiGor ( 2014-05-22 13:12:14 +0200 )edit

Please remove the manually installed German dictionary extensions ("User") via Extension Manager and restart LibreOffice (maybe twice). If this doesn't help, close LibreOffice, go to your LibreOffice user profile, rename the folder "bundled" (path: LibreOffice\4\user\extensions\bundled) to "bundled-old", restart LibreOffice (maybe twice).

manj_k gravatar imagemanj_k ( 2014-05-22 13:52:48 +0200 )edit
0

answered 2014-05-22 11:30:42 +0200

iGor gravatar image

updated 2014-05-22 11:32:29 +0200

I still have that problem. I've installed the extensions, which are correctly installed and activated, without any error message. I've restarted LibreOffice, I don't use the quickstarter. I've even restarted the whole computer, but no way. In the Options, Linguistics, there's no language corrector for german.

Some printscreens :

Installed dictionnaries

Missing correctors

Missing languages

edit flag offensive delete link more

Comments

1

The funny thing is, that this is working on other Windows 7 installed computers than the ones I'm using at work. I have to ask the IT here.

iGor gravatar imageiGor ( 2014-05-22 15:28:42 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-02-20 09:52:09 +0200

Seen: 9,612 times

Last updated: May 22 '14