Ask Your Question
1

Headings, Breaks, Page Numbering in a Master document [closed]

asked 2014-02-22 00:57:02 +0200

oliver.kellow gravatar image

updated 2014-02-22 14:24:31 +0200

I am following the Open office guide but it makes no sense to me and all the page styles they use in the examples don't exist in my document..

I have:

  1. Changed my template/Style's Heading 1 to have Textflow->Break unchecked
  2. Inserted "text" things between all my chapters.
  3. Inserted a page break in the master document "text" gaps between chapters.

At this point the page numbering resets What is the Property/variable of the Page break or the Heading/text flow that allows the numbering to continue?

The guide starts talking about page styles and "blank paragraphs" that I do not have ( even with non-printing characters on). I'm assuming that this is due to the Libre/openOffice differences.

This is a master document with custom styles. For it to be submissible I need page numbering and a TOC that includes the numbered hierarchy (outline?)

Please help, i want to cry- i have been trying to get the numbers to work for days... Not to mention TOC numbering.

GUIDE AT: https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Recommended_method Step 5.8 and 5.9

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 11:56:51.125019

Comments

Please add a reference for "Open office guide" (download URL and chapter number).

Regina gravatar imageRegina ( 2014-02-22 13:36:07 +0200 )edit

Ok, Done, what is the variable in Header 1 that I have to alter to stop it from declaring a new page?

oliver.kellow gravatar imageoliver.kellow ( 2014-02-23 11:49:31 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-02-22 19:09:06 +0200

Regina gravatar image

updated 2014-02-23 16:40:30 +0200

When you get an unwanted restart of page numbering, then there is a manual page break involved. Please open that sub-document where you see the wrong page numbering. Open the Format > Paragraph of the first paragraph of that sub-document. Make sure, that page break is unchecked in dialog page "Text Flow". If your template contains different page styles, try to use "default style" in the sub-document. When a document uses another page style than "default style", then a page break is inserted automatically in the first paragraph.

The section "Break" in the dialog page "Text Flow" has a field for page numbers. The value has to be zero to continue with previous counting. image description

Remember, that for the combination of master document with its sub documents, changing styles have to be done in the template, not in the documents, otherwise the parts will have inconsistent style informations.

For generating a TOC, you have to format the headings with paragraph style "Heading 1", "Heading 2", ... corresponding to their logical level. Then enable numbering in Tools > Outline numbering in the master document, make sure the levels have assigned this paragraph styles. Never use any list button for chapter headings. It is the same for master documents as for normal documents. Using the defaults in outline numbering makes that the default works in TOC too.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-22 00:57:02 +0200

Seen: 3,242 times

Last updated: Feb 23 '14