Ask Your Question
1

I want to get out of Read Only to normal page I can edit

asked 2021-04-11 08:14:12 +0200

emel gravatar image

I want to get out of Read Only mode, back to a page i was writing and editing

edit retag flag offensive close merge delete

Comments

You are going to have to supply more information, see Ask/Getting started

Click Help > About LibreOffice, click the icon next to Version information to copy the text to the clipboard. Click edit just below your question and paste the information under your previous text.

Add any other info, especially what happened at the time between which you could no longer edit your document, e.g. error messages, warnings, etc. Save your question.

Earnest Al gravatar imageEarnest Al ( 2021-04-11 08:38:26 +0200 )edit

Have you already saved the file? What about menu Edit - Edit Mode?

Add Answer is reserved for solutions.

LeroyG gravatar imageLeroyG ( 2021-04-11 17:22:16 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-04-19 04:42:09 +0200

Earnest Al gravatar image

No response to questions so here is a scattergun guess.

It is probably an anti-ransomware setting somewhere

Mac

You probably need to give LibreOffice full disk access from System Preferences > Security & Privacy. See this site on how to do it if you aren't sure: https://macpaw.com/how-to/full-disk-a... .

Windows

Allow LibreOffice access to controlled folder

The below numbered list is from Use the Windows Defender Security app to allow specific apps

  1. Open the Windows Security by selecting the shield icon in the task bar or searching the start menu for Defender.
  2. Select the Virus & threat protection tile (or the shield icon on the left menu bar) and then select Ransomware protection.
  3. Under the Controlled folder access section, select Allow an app through Controlled folder access
  4. Select Add an allowed app and follow the prompts to add apps. You need to allow access to soffice.bin

Turn Off Defender (Maybe for dual boot)

Select Start  > Settings  > Update & Security  > Windows Security > Virus & threat protection. Under Virus & threat protection settings, select Manage settings. Under Controlled folder access, select Manage Controlled folder access. Switch the Controlled folder access setting from On to Off.

3rd Party Anti-virus

If you do have a third party anti-virus go into settings and then look for something like anti-ransomware or folder protection. Have a look at the blocked apps list, if you see soffice.bin in there change it to Allowed (you might have to read AV help if not obvious). Otherwise go to the Allowed Apps setting and allow soffice.bin, this might not be easy so you might have to change the file type to All to see it and to add the Allowed list. Note that 3rd party anti-virus might make files Read Only so you can create a new file but you can't save it subsequently. Sometimes, you might need to reboot after allowing a program access.

Cheers, Al

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-04-11 08:14:12 +0200

Seen: 50 times

Last updated: Apr 19