Ask Your Question
0

Math equation box cuts off some of the equation

asked 2021-04-16 12:36:22 +0200

Phillipth gravatar image

updated 2021-04-16 17:53:15 +0200

When editing my mathematical equation everything is fine (top image), but when I go out of that environment I see that the bottom part of the equation has been cut off (bottom image) and I cannot resize the bounding box. How do I stop this from happening?

EDIT: The comment by Opaque is what solved the issue for me, thank you! As suggested, the version I am using and my operating system are shown below:

Version: 7.0.0.3 (x64) CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win

image description

edit retag flag offensive close merge delete

Comments

Since this doesn't happen on my installations (LibreOffice 6.4.7.2 / 7.0.5.2 / 7.1.2.2 on openSUSE Leap 15.2) it might be helpful

  • providing a sample file
  • providing information about your LibreOffice version (Help - About LibreOffice) and operating system
  • tell the save format (.odt or some other format)

Anyway: To change the spacing you need to do that, while in math using Format -> Spacing.... Select in drop down Category: Borders and get:

image description


Please do not use Add Answer but edit your original question to enhance the details of your question and/or to upload sample file(s) (answers are reserved for solutions to a problem on this Q&A site). Thanks in advance …

Opaque gravatar imageOpaque ( 2021-04-16 13:19:43 +0200 )edit

This solved it! Thank you very much!

Phillipth gravatar imagePhillipth ( 2021-04-16 14:49:09 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-04-16 13:27:45 +0200

ajlittoz gravatar image

Increase the bottom padding with Format>Spacing, Category = Borders. Look at the bottom parameter. Warning! I don't know which unit is used. It is probably a percentage. You then have to be "generous" in your increase.

In Writer, formulas are formatted with frame style Formula. You could change the padding distance in the Borders tab, but I don't think this will fix the clipping because padding is added around the formula as returned by Math.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

Thank you for this answer, it did have to do with the borders, the way Opaque explained it to me in the comment he placed is how I fixed it (editing the borders within the math environment).

Phillipth gravatar imagePhillipth ( 2021-04-16 14:48:56 +0200 )edit
0

answered 2021-04-16 13:51:26 +0200

keme gravatar image

updated 2021-04-16 13:55:38 +0200

In cases I have seen, this is a rendering artifact only occurring in the edit window. You can determine whether this is also true for your case:

  • Menu item File - Print preview
    ... or ...
  • Export to PDF.

If the preview/export also displays the cutoff, the issue may be rectified by altering spacing. See other answer(s) to your question. This also means that it is a bug, most likely OK in the last "Deployment version" (7.0.5 at the time of writing), and should be reported if it occurs in the latest "enthusiast version" (currently 7.1.2).

If preview/export is OK (no cutoff), the problem is with some graphics subsystem, either within LibreOffice or in your operating system. It will not affect your finished document, but may still be annoying at edit time.

A few steps to try to rectify the problem:

  • Tools - Options, expand LibreOffice branch and select View. Experiment with different settings for Skia rendering.
    Restarting LibreOffice (possibly even reboot) may be required to make change effective.
  • Install system updates.
  • Download and install specific graphics (video, screen) drivers from equipment (screen, graphics card, motherboard) manufacturer.
edit flag offensive delete link more

Comments

Thank you for the reply, I tested the print preview but this didn't solve the issue, it ended up being the border spacing of the math equation box as Opaque suggested in the comment.

Phillipth gravatar imagePhillipth ( 2021-04-16 14:50:33 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-04-16 12:36:22 +0200

Seen: 47 times

Last updated: Apr 16