Can Writer have a memory leak?

asked 2021-05-10 01:27:20 +0200

Vengeance gravatar image

updated 2021-06-14 21:38:37 +0200

Alex Kemp gravatar image

Never had a problem with Libre Writer before 2021. Been using it since 2012. Now, while writing a document, my typing is often interrupted by what feels like a memory backup process. Sometimes, there is no way to stop it. Sometimes, it is fixed by rebooting. It is as if there is a memory leak, and it's very unpleasant; enough for me to consider using a different word processing application like Google Docs or MS Word.

This problem occurs in no other program, application or process.

System specs: Lenovo Ideapad L340 (gaming laptop) Windows 10 (64 bit) Intel i5-9300H @2.4 Gz 8G RAM Geforce GTX 1650 w/ 8G Kensington accessory keyboard (USB 3) Logitech M705 mouse

Please let me know your thoughts and remedies.

edit retag flag offensive close merge delete

Comments

1

What does Task Manager (Ctrl+Alt+Del > Task Manager > Processes) say is using the resources?

Earnest Al gravatar imageEarnest Al ( 2021-05-10 01:57:23 +0200 )edit
2

...by what feels like a memory backup process.

If it is set for you, there is a backup in LibreOffice.

Choose Tools>Options>Load/Save>General from the menu.

There at "Save" you probably have a check mark at "Save AutoRecovery information every xx minutes".

ebot gravatar imageebot ( 2021-05-10 06:35:55 +0200 )edit
1

If you save auto recovery data every 10 minutes or more often, and you work on a large file, you will notice that Writer blocks all changes to the document while it's being saved, it does take time.

floris v gravatar imagefloris v ( 2021-05-10 11:45:01 +0200 )edit

@ebot@floris v Thank you for your suggestions. This seems to have fixed it. However, the work progress backup was set to every 30 minutes. Unclear as to why it would slow my work down in almost every word.

Vengeance gravatar imageVengeance ( 2021-05-11 10:19:13 +0200 )edit
1

I disabled that option quite a while ago and instead use Ctrl+S a lot to save my work. That may be more reliable than autorecovery. I still have to wait for the save operation to complete, but at least I know when that's going to happen, so I can still feel being in control.

floris v gravatar imagefloris v ( 2021-05-11 13:34:51 +0200 )edit

@floris v Yes, I always use Ctrl-S to save and never knew that autosave was checked. Is it a default setting?

Vengeance gravatar imageVengeance ( 2021-05-11 22:06:03 +0200 )edit

Not sure, but it's amazing what changes you can make without even noticing it. 🤔 Anyway, it's always a good idea to check user settings regularly, especially when odd things happen.

floris v gravatar imagefloris v ( 2021-05-12 19:31:46 +0200 )edit

It might be the Windows Indexing service re-reading your file after each change. I changed my settings for it to just index file properties and not contents, Control Panel > Indexing options > Advanced > File Types. Of course this makes Windows Search incredibly slow because it still wants to look inside every file even though I only ever want to search in file names so I don't use it. I installed Everything which indexes only files properties, very speedy indexing and instant search.

Earnest Al gravatar imageEarnest Al ( 2021-05-12 23:29:39 +0200 )edit