Ask Your Question
0

Copy/Paste from web page to text document.

asked 2014-03-07 23:47:41 +0200

TerryB gravatar image

updated 2015-09-11 20:25:58 +0200

Alex Kemp gravatar image

When I paste the document into a text document I get grey bars on either side of what seem to be text format changes, eg bold, italics, underlined text. Each bar can be eliminated by back spacing and then spacing, but this gets tedious. Is there some way to avoid the bars or remove them all at once?

I am using ver 4.0.4.2 in Windows 8

edit retag flag offensive close merge delete

Comments

You may try Ctrl+F8.

manj_k gravatar imagemanj_k ( 2014-03-08 00:51:40 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-09-20 12:57:42 +0200

Alex Kemp gravatar image

Hi Terry

What may assist you is to understand what happens when you paste into a LO document from a MIME-rich format such as a web-page:-

The MIME-Artist:

There are 2 paste methods in Writer:-

  1. (menu):EditPaste [Ctrl+V] (paste default MIME)
  2. (menu):EditPaste Special... [Ctrl+Shift+V] (paste from menu of MIME)

At a minimum, Ctrl+V pastes the top choice in (2) (Shift+Insert normally also works, with Ctrl+Insert as an alternative for Ctrl+C). I did a quick test on these web-pages just now & got the following options with Ctrl+Shift+V:-

  1. "Unformatted text" [MIME: 'text/plain'] (the 1st one, and thus the default)
  2. "HTML (HyperText Markup Language)" [MIME: 'text/html']

Depending on the web-page, it would not be unusual to have 4 choices, and it is normal in my experience for the 'text/html' option to be first & not last. That means that a Paste [Ctrl+V] will add many non-default formatting features to your LO page, probably including fonts that are not part of the existing page.

The Bottom Line:

Use Paste Special... [Ctrl+Shift+V] (and choose 'text/plain') when you paste from a web-page.

PS

Paste Special... is also available when you do internal pasting in LO/OO, which can often help unpick unneeded formatting.

edit flag offensive delete link more
0

answered 2015-09-20 00:59:18 +0200

LKeithJordan gravatar image

As I was beginning to answer this question, I noticed that the original post is over a year old. Since it is still unanswered, I'll add my post in hopes someone can benefit.

I haven't seen this precise effect before, but I have experienced other formatting issues when copying text from a web page and pasting it directly to a word processor such as MS-Word or LO Writer. My solution is to use a plain text editor as an intermediate application. On a Windows OS machine, I use Notepad.

Pasting the copy buffer to a plain text editor removes almost all formatting. (In some cases, I may have to also remove unwanted bullet characters, hard returns, etc., but this is quickly accomplished.) If you are using Notepad, be sure to disable word wrapping before pasting the text into this application.

Once I have prepared the text, I copy and paste it into my word processor document. In most cases, the document formatting in the receiving area applies to the pasted text automatically. Otherwise, I format the pasted text as necessary.

I use this approach often. It is much easier than other methods I have tried.

edit flag offensive delete link more
0

answered 2015-09-20 05:46:33 +0200

desci gravatar image

You should use CTRL+SHIFT+V when pasting, and then select "Unformatted Text" or other desired format on the following box.

There is another shortcut for unformatted text (which is probably the best fit for you), that is CTRL+ALT+SHIFT+V.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2014-03-07 23:47:41 +0200

Seen: 2,864 times

Last updated: Sep 20 '15