Ask Your Question
0

Executing Writer on OS X [closed]

asked 2014-03-10 03:01:15 +0100

Sean Stanford gravatar image

updated 2015-09-04 12:30:33 +0100

Alex Kemp gravatar image

When installing LO on Linux operating systems, I get the menu options to execute ever application within the suite separately. In OS X, I do not. Now a feature in 4.2.0+, it shows a list of documents I've created in the suite. I want none of this. All I want to do is execute Writer outside the suite like I do in Linux. How is this possible?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 07:22:10.116190

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-12 13:27:35 +0100

oweng gravatar image

updated 2014-03-13 07:58:20 +0100

I have scrapped my original answer in favour of a short HOWTO for the bash script method mentioned by Alex:

  1. Open a text editor.
  2. Edit the new file to include:

    #!/bin/bash

    /Applications/LibreOffice.app/Contents/MacOS/soffice --writer

  3. Save the file to the desktop as "Writer.command" (e.g., for the Writer component).

  4. Ensure this file is executable ($ chmod +x Writer.command in terminal).
  5. Copy this file and rename it as required per component, editing the --writer parameter as necessary to --calc, --impress, --draw, --base, or --math.
  6. Launch the required component by double-clicking on the respective script.

Note: This works under MacOS 10.6.8 with LO v4.2. Please comment if it works (or not) under more recent versions of MacOS / LO.

edit flag offensive delete link more

Comments

Following your commands perfectly, a terminal window appears with the following message:

Desktop/Writer.command ; exit; -bash: /Users/robert/Desktop/Writer.command: cannot execute binary file logout

[Process completed]

…and nothing happens. I triple checked the commands, didn't miss anything. the path and filenames are correct including the executable bit on the script file.

Sean Stanford gravatar imageSean Stanford ( 2014-03-13 13:15:33 +0100 )edit

Make sure there is no blank line between the first and second line in the script. The formatting above includes a blank line between the two lines if cut/paste.

oweng gravatar imageoweng ( 2014-03-13 13:48:18 +0100 )edit

No blank line exists. Still, I can't get it to work. Honestly, I'm not going to worry about it that much, it's not a do-or-die request, but I would definitely love to see this as an option in a future version (install LO as single office concept or individual items so only one or two can be installed).

Sean Stanford gravatar imageSean Stanford ( 2014-03-13 15:45:00 +0100 )edit
1

answered 2014-03-12 13:59:12 +0100

Alex Thurgood gravatar image

Short answer : you can't, all of the modules are contained within the app bundle, that is how it works on OSX. On Linux, those icons you see in the desktop menu (and draggable to your desktop or launchbard) are shortcuts to swriter, scalc, simpress bash commands which in turn reference the soffice binary with the options --writer, --calc, --impress, --base, etc. On OSX, you could always try creating a bahs shell launcher referencing the corresponding command in the app bundle that you could then drag to your Dock, but I haven't tried that.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-03-10 03:01:15 +0100

Seen: 1,524 times

Last updated: Mar 13 '14