Ask Your Question
1

Autocorrect working for non-english language.

asked 2014-03-15 22:29:08 +0200

Makaki gravatar image

updated 2015-08-29 10:32:11 +0200

Alex Kemp gravatar image

I write documents in English and in Spanish. When I write document in Spanish, even though I have set the language "for all text" to Spanish, AutoCorrect still works in English. So it mistakenly changes words that would be correct in Spanish, but it finds are wrong in English.

For example: the word "anual" would be auto corrected to "annual". But the former is the correct way to write the word in Spanish.

How can I limit AutoCorrect to only work in English, without constantly having the turn the feature on and off?

edit retag flag offensive close merge delete

Comments

Which version of LibO and which OS are you using?

ROSt52 gravatar imageROSt52 ( 2014-03-16 03:20:00 +0200 )edit

What language is shown in the status bar (at the bottom of the window) when you set the cursor into the line of the corrected word?

manj_k gravatar imagemanj_k ( 2014-03-16 11:40:17 +0200 )edit

I have this problem with LO 4.2.6.3 on Ubuntu 14.0 (with Polish language). On the status bar I see Polish.

Line gravatar imageLine ( 2014-10-09 15:12:57 +0200 )edit
1

the same in 4.2.7.2, auto correct does not follow text and corrector language but the system default

cipricus gravatar imagecipricus ( 2014-12-31 12:37:07 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2016-03-01 16:13:10 +0200

cipricus gravatar image

updated 2016-05-02 19:12:21 +0200

First of all: UPDATE! -- Version 5.1.2.2 doesn't seem affected by this anymore.


On version 4.7, a similar problem in Romanian: here.

The idea is to set your intended language as default in Options - Language Settings - Languages - Default Languages for Documents.

In my case this looked like a small bug that was fixed by changing at least once the English US default language for documents. (I can even roll back to English US for default language for documents and if I change a paragraph language to Romanian the problem is absent.)

I hope it works for Spanish too.


After testing with the Spanish dictionary from here I don't have your problem. But I have already switched my default language for documents at least once already to fix my problem.


In case this kind of problem happens in any case there is the more radical solution of disabling 'Use replacement table' - 'Autocorrect while typing' under 'Tools - AutoCorrect - AutoCorrect options', Options tab. (To select the language first go to the 'Replace' tab.)

image description

edit flag offensive delete link more
0

answered 2016-05-02 22:35:10 +0200

RGB-es gravatar image

I think this problem is associated to a report I filed some time ago:

Bug 32357 - Autocomplete is not language sensitive

https://bugs.documentfoundation.org/s...

edit flag offensive delete link more

Comments

I had a version of this bug where no English paragraph was present in a document and still the auto-corrector suggested English words. That was maybe because English was the system and interface language. All this was fixed in 5.2 version it seems.

cipricus gravatar imagecipricus ( 2016-05-03 11:07:41 +0200 )edit
0

answered 2014-12-31 15:14:59 +0200

ROSt52 gravatar image

@Line - Because you answered the question raised by @manj_k.

I would give it one try and reset the user profile. If this doesn't help I feel we have a bug..

Details for user profil reset: https://wiki.documentfoundation.org/U...

Bug report: https://www.libreoffice.org/get-help/...

edit flag offensive delete link more
0

answered 2016-03-02 11:30:49 +0200

petermau gravatar image

You could try using Paragraph Styles to select the language you wish to use as described in https://ask.libreoffice.org/en/questi.... Then when you modify the text you should have autocorrect selecting the correct language. At least it works for me...Peter

edit flag offensive delete link more

Comments

the problem is that of wrong auto-correction to English when a different language is selected: this problem is not affected by the way that language is selected (with a style or otherwise)

cipricus gravatar imagecipricus ( 2016-05-02 17:46:18 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2014-03-15 22:29:08 +0200

Seen: 834 times

Last updated: May 02 '16