Ask Your Question
0

How do I install LibreOffice on Linux without root priviledges ? (user mode ?) [closed]

asked 2014-03-27 20:07:32 +0100

Edgardo gravatar image

updated 2015-09-09 20:34:59 +0100

Alex Kemp gravatar image

I'd like to install the latest LibreOffice (4.2....) on RHEL5 without root permissions. I think that is called "user mode", isn't it?

Is this possible? Are there instructions available?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 15:45:31.663662

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-28 19:56:33 +0100

Edgardo gravatar image

updated 2014-03-29 00:21:28 +0100

oweng gravatar image

Thank you for the comments and the link to the rpm guide! In summary: I'm able to install and run LibreOffice in User Mode.

Details: I was ready to use the instructions to relocate the installation from the rpm guide, when I read in the "install" file that comes with LibreOffice that there is another option. This is what I ended up doing:

Download Linux X64 (rpm) 4.2.2: LibreOffice_4.2.2_Linux_x86-64_rpm.tar.gz from http://www.libreoffice.org/download/l...

Then extract to a directory using: tar xvzf [file name].tar.gz

cd to the new directory and look inside the "install" file, or run: install -help It says that it's a User Mode Installation script. I decided to try it out, even though it says that it's not intended for use in a production environment.

To install inside ~/bin, run: install -lU ./RPMS ~/bin/libreoffice4.2 It automatically lists the packages and the paths, then installs the packages, uninstalls them, installs updates, and creates a link from the home directory to the main executable at ~/bin/libreoffice4.2/opt/libreoffice4.2/program/soffice

To test from the home directory: ./soffice& LibreOffice started and worked well, although I got these messages:

Xlib:  extension "XINERAMA" missing on display ":1006.0".
(soffice:12288): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12288): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12288): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12288): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12288): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12288): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12296): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12296): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12296): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12296): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12296): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12296): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12296): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12296): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'

The second time I started it, it also worked well, and I received a few less messages:

Xlib:  extension "XINERAMA" missing on display ":1006.0".
(soffice:12400): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12400): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12400): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12400): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
(soffice:12400): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GtkSettings' has no property named `gtk-fontconfig-timestamp'
(soffice:12400): Gtk-WARNING **: gtkwidget.c:7583: widget class `GtkDialog' has no property named `content-area-spacing'
edit flag offensive delete link more
1

answered 2014-03-28 01:51:34 +0100

oweng gravatar image

You are likely going to have to set the install location for the RPM to your user directory e.g., /home/<user>/LibreOffice/. This guide gives instructions on using rpm without root privileges. In that guide 7.7. deals with using relocation, although to what degree this will work with the LO RPMs I am unclear. Please report back if you are successful and what worked (or did not).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-03-27 20:07:32 +0100

Seen: 2,301 times

Last updated: Mar 29 '14