Ask Your Question
0

Install Language packs for Libreoffice 4.2 [closed]

asked 2014-04-02 15:53:36 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have installed Libreoffice 4.2.0.4 on my CentOS 6.5, following the instructions from [here ]. ( http://www.tecmint.com/install-libreo... ).

What i am trying actually is to convert the RTF to PDF document using the Libreoffice headless command from php:

exec('libreoffice4.2 --headless --invisible --norestore --convert-to pdf --outdir /pdf /docs/test.rtf');

But i see that the converted PDF file is not containing the text from languages like Chinese, Japanese, Korean. So i think i need to install the language packs for Libreoffice. I have tried searching them through command like:

yum search libreoffice4

But see that there is no language pack listed there. I only see the following list:

libreoffice4.2.x86_64 : Brand module for LibreOffice 4.2 .0.4
libreoffice4.2-base.x86_64 : Base brand module for LibreOffice 4.2 .0.4
libreoffice4.2-calc.x86_64 : Calc brand module for LibreOffice 4.2 .0.4
libreoffice4.2-dict-en.x86_64 : En dictionary for LibreOffice 4.2 .0.4
libreoffice4.2-dict-es.x86_64 : Es dictionary for LibreOffice 4.2 .0.4
libreoffice4.2-dict-fr.x86_64 : Fr dictionary for LibreOffice 4.2 .0.4
libreoffice4.2-draw.x86_64 : Draw brand module for LibreOffice 4.2 .0.4
libreoffice4.2-en-US.x86_64 : Brand language module for LibreOffice 4.2 .0.4
libreoffice4.2-freedesktop-menus.noarch : LibreOffice desktop integration
libreoffice4.2-impress.x86_64 : Impress brand module for LibreOffice 4.2 .0.4
libreoffice4.2-math.x86_64 : Math brand module for LibreOffice 4.2 .0.4
libreoffice4.2-ure.x86_64 : UNO Runtime Environment .0.4
libreoffice4.2-writer.x86_64 : Writer brand module for LibreOffice 4.2 .0.4

Is there a way of installing the language packs for Chinese, Japanese and Korean ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 18:39:55.912722

2 Answers

Sort by » oldest newest most voted
1

answered 2014-04-03 09:43:28 +0200

shasi gravatar image

Well, i found that the issue lies in the lack of language support for the CentOS. When i installed missing language packs for CentOS, the corresponding PDF files showed correct data.

Here i got useful information.

So what i did was: yum groupinstall "Chinese Support", yum groupinstall "Japanese Support", yum groupinstall "Korean Support".

edit flag offensive delete link more

Comments

1

@shasi, thanks for reporting back.

oweng gravatar imageoweng ( 2014-04-03 12:46:05 +0200 )edit
1

answered 2014-04-03 05:13:03 +0200

oweng gravatar image

I think the issue is more likely to be related to text encoding or font support than a missing language pack. How is the East Asian text encoded e.g., UTF8, UTF16LE, BGnnnn? Which font is the text set in? Has the Asian language option been checked under Tools > Options... > Language Settings > Languages > Default languages for documents section?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-04-02 15:53:36 +0200

Seen: 4,946 times

Last updated: Apr 03 '14