Ask Your Question
1

Why the super slow saves in Calc? [closed]

asked 2014-04-21 01:18:55 +0200

anapto gravatar image

updated 2015-09-03 02:29:40 +0200

Alex Kemp gravatar image

I use version 4.2.3.3 on Windows 8.1 with the latest spring update. I have an HP Pavilion with an AMD processor, 6 GB RAM. Since upgrading LibreOffice to the 4.0 series, saving large spreadsheets is agonizingly slow. I can go get a drink or go to the restroom before it's done saving, several minutes. The title bar shows that Calc goes into a (Not Responding) mode for a minute or two while saving. I regularly use a 7,000 line spreadsheet with about 60 columns, few and simple calculations, it's mostly just a database of information. These slow saves are aggravating. Thanks for any fixes or ideas on how to overcome this sluggish performance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-26 09:47:01.759267

2 Answers

Sort by » oldest newest most voted
0

answered 2014-04-21 03:25:43 +0200

oweng gravatar image

Try and remove as much direct formatting as you can i.e., formatting applied via keyboard shortcut (CTRL+B) or toolbar button. Instead use styles (via the Styles and Formatting panel). This should both reduce the file size and increase the spreadsheet performance. Also, under File > Properties... > Font tab > uncheck the "Embed fonts in the document" option. If numerous fonts are being used and the font file sizes are large this can result in larger files and slower saves.

edit flag offensive delete link more
0

answered 2014-05-27 05:46:44 +0200

Francewhoa gravatar image

updated 2014-06-25 17:40:47 +0200

Here is a temporary workaround that resulted in huge performance improvement during save: Using LibreOffice save your document in Microsoft's format ".xlsx". Very fast performance, down from 40 seconds to 1 second or less in my case. But this is just a temporary workaround for me. I would prefer using ".ods" format because: it's the default format for LibreOffice; it's open source; and own by a community not own by a corporation.

Note that ".xlsx" might not match your needs, as some features are not supported, details in the table at http://office.microsoft.com/en-001/ex...

I can confirm this issue. I created a bug report at https://bugs.freedesktop.org/show_bug...

edit flag offensive delete link more

Comments

I use 4.2.3.3 on Linux x64 to edit 174,4 KiB size *.ods file. It takes 10 seconds to open. I followed your advice save in xlsx format and got 12 seconds on opening. I have an HP Mini with an Intel 2 core 1000 MHz processor, 2 GB RAM.

denis.polkovnikov gravatar imagedenis.polkovnikov ( 2014-05-28 06:41:29 +0200 )edit

The temporary workaround performance improvement is on save not load. That's the title of the thread ;) I just updated my answer to clarify.

BTW that slow save issue is fixed in LibreOffice 4.2.4.2. Using Debian Wheezy 7.5 at 64 bit

Francewhoa gravatar imageFrancewhoa ( 2014-06-25 17:44:04 +0200 )edit

Question Tools

3 followers

Stats

Asked: 2014-04-21 01:18:55 +0200

Seen: 7,113 times

Last updated: Jun 25 '14