Ask Your Question
1

Could not start printer - LibreOffice 4.3.2.3 - I get an error message on about 50% of print attempts to Laserprinter [closed]

asked 2014-05-03 19:50:06 +0200

RogerT gravatar image

updated 2015-09-06 20:34:04 +0200

Alex Kemp gravatar image

I am running Red Hat 6.5 (64 bit). After an upgrade to the current version of Libre Office, I now get an error message trying to print on an HP LaserWriter P1606d. The error message pops up "Could not start printer. Check your printer configuration." Then the document prints. The error message appears about 50% of the time. After appearing, the next print job usually proceeds normally.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-22 15:34:10.327722

Comments

v4.3.2.3 or v4.2.3.3? Please edit your question for clarity. Also, which version of CUPS are you running? All versions prior to v1.7.0 have a problem with timeout and reconnection (refer bug fdo#56344).

oweng gravatar imageoweng ( 2014-05-04 11:39:20 +0200 )edit

I use Ubuntu on my work machine, and get exactly the same behaviour - but I thought it had to to with my recent upgrade to 14.04. I can't check which LibO version right now, but it's going to be latest available, which I think is 4.2.3.3. I checked this on AskUbuntu last week and it wasn't reported there (still isn't), so thought it was "just me". Looks more likely to be LibO now, though.

David gravatar imageDavid ( 2014-05-04 14:46:36 +0200 )edit

Just to confirm, on Ubuntu 14.04 I have LibO 4.2.3.3 Build ID: 420m0(Build:3). The Help > About LibreOffice dialog includes: "This release was supplied by The Document Foundation, Debian and Ubuntu." (I prefer a comma after "Debian". :) I've got v. 1.7.2-0ubuntu1 for CUPS. This behaviour has only appeared since upgrade. Printing from other software (e.g., PDF) is just fine - no glitches.

David gravatar imageDavid ( 2014-05-05 09:25:47 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-05 09:55:16 +0200

David gravatar image

updated 2014-05-10 12:36:57 +0200

I was going to file a bug report, but it is already there as fdo#77776 - with a long comment trail! Looks like a fix might be in place ... in 4.2.4.2! So will just live with it until upgrade is available via the standard PPAs.

UPDATE - I just got 4.2.4.2 via autoupdate, and can confirm that this is now fixed (at least for me! on Ubuntu 14.04).

edit flag offensive delete link more

Comments

Please clarify "autoupdate." Software Center and Synaptic are still showing 4.2.3

Jim Greene gravatar imageJim Greene ( 2014-05-13 16:09:16 +0200 )edit

If you updated to 14.04 from 13.10 (or possibly previous LTS release?), then I think the PPAs get disabled. I used the Y-PPA-Manager tool after updating, and I got 4.2.4.2 through the normal Software Updater mechanism. I'm looking at Synaptic as I type: the current version available to me (and installed on my machine) is 1:4.2.4~rc2-0ubuntu1~trusty1 which is also showing as the latest available. Hope that's a help!

David gravatar imageDavid ( 2014-05-13 18:09:26 +0200 )edit

That worked. Thanks for your assistance.

Jim Greene gravatar imageJim Greene ( 2014-05-14 07:10:17 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-03 19:50:06 +0200

Seen: 7,647 times

Last updated: May 10 '14