Ask Your Question
1

LibreOffice 4.2.3 - very slow startup on Ubuntu 14.04 [closed]

asked 2014-05-05 18:03:33 +0200

David gravatar image

updated 2015-08-31 22:48:43 +0200

Alex Kemp gravatar image

Most times when I start LibreOffice on 4.2.3.3 (under Ubuntu 14.04), the application goes grey for 10+ seconds while the toolbars appear overlapped; then it clears and the application is launched.

This is very odd behaviour, and unlike the fast-opening LibO I used to enjoy. The problem is complicated, though, since the LibO version was updated at the same time as upgrading the OS to the current (14.04) version.

Are any other LibO users expeiencing this behaviour? I did a search for a relevant bug, but couldn't spot this one. Help and/or comments appreciated!

Update - the "fix" below helps enormously, but still start-up feels glitchy. I still get intermittent "grey-outs" on launch ("warm" ones, after the app has already been run and closed), but I can't discern a pattern. When it starts, it starts quickly - but sometimes ... it doesn't. Still interested in anecdotal comments of others using LibO on Ubuntu 14.04 especially. [2014.05.09]

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 23:36:08.797928

Comments

I am also having this problem.

ron gravatar imageron ( 2014-05-06 21:21:18 +0200 )edit

@Ljiljan - that fixed it for me! Before enabling "Quickstarter", launching Writer took ~20s : about the first 10s with the menu bars overlapped + 10s more with it "greyed" out. With Quickstarter enabled, it launches (from "cold") in about 5-8s. MUCH better - thank you! If you promote your comment to an answer, I'll "accept".

David gravatar imageDavid ( 2014-05-07 09:13:36 +0200 )edit

Dear David, I promoted my comment to answer. I am glad this helped you.

Ljiljan gravatar imageLjiljan ( 2014-05-07 23:37:11 +0200 )edit

I am really not expert, but I believe this problem has to do something with Unity menu integration process... In my case, LibreOffice starts fast with QuickStarter, no gray phase, however "mouse busy icon" goes away after 10 seconds. This is bug I am experiencing ever since version 4.1. was introduced. You think these two problems could be connected? I recorded my problem with RecordMyDesktop application: http://youtu.be/dabnfddx5xE

Ljiljan gravatar imageLjiljan ( 2014-05-10 12:19:33 +0200 )edit

@Ljiljan - I have exactly that behaviour. I just got the upgrade to 4.2.4.2 via autoupdate, and the startup is much quicker. I get the same "spinner" as you do on subsequent launches (not, now, the first time after bootup?). It is odd, and I am only a "simple user", so without insight into what is going on. I am also watching AskUbuntu in case something relevant shows up there, but so far I haven't noticed anything. Thanks for your input!

David gravatar imageDavid ( 2014-05-10 12:35:12 +0200 )edit

@Ljiljan - two quick updates: (1) I just got the 4.2.4.2 update on my ancient Toshiba laptop running Linux Mint 13 LTS Xfce (based on Precise/12.04) and LibO starts quick and no "spinning/busy-cursor" strangeness. I'm guessing that must be related to Unity. (2) I put a post about this on AskUbuntu but no one seems very interested. :(

David gravatar imageDavid ( 2014-05-13 22:32:13 +0200 )edit
1

It's definitely Unity... I installed GNOME shell under same operating system, and no such problem anymore... I think I will swich to different Ubuntu-based distribution :)

Ljiljan gravatar imageLjiljan ( 2014-05-15 08:55:10 +0200 )edit

Not really an option for me - I just tried installing xubuntu-desktop and tried a session but ... not really worth it for me at the moment. I'll hope that the Unity integration improves. Thanks for your input!

David gravatar imageDavid ( 2014-05-15 12:35:44 +0200 )edit

I was trying different linux user interfaces/ shells today ( http://askubuntu.com/questions/65083/... ). After trying 10 user interfaces and after my system started to behave strange, I think I will reinstall my system :) I will continue to use Unity user interface as well and continue hoping that this annoying bug will be fixed.

Ljiljan gravatar imageLjiljan ( 2014-05-15 14:10:39 +0200 )edit

Idea to test: You can completely remove LibreOffice installed from Ubuntu Software Center. Download latest version from official web site and install it using instruction (they are quite simple). After this, menu integration with Unity is disabled... I tested it and it works fine, but some others problem could occur... so far it's good

Ljiljan gravatar imageLjiljan ( 2014-05-15 20:44:33 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-05-07 08:12:08 +0200

Ljiljan gravatar image

updated 2014-05-07 23:37:38 +0200

You can enable System Quickstarter (Tools -> Options -> LibreOffce -> Memory).

edit flag offensive delete link more

Comments

Takes my startup time to just over 5 seconds. Better than 20+ every time! Odd that this didn't happen before, but glad to know this "fix". Thanks!

David gravatar imageDavid ( 2014-05-08 09:00:25 +0200 )edit
0

answered 2014-07-19 16:25:02 +0200

satupe gravatar image

I am a Kubuntu 14.04 user. In my case, the problem was LibreOffice 4.2.3. I have and 11,000 row, 60 column LibreOffice spreadsheet loaded with macros. The sheet would sort in less than 5 seconds using Ubuntu 13.10 (Unity). It would take 15 MINUTES (if LibreOffice 4.2.3 didn't crash!) in Kubuntu 14.04 to sort the same sheet. My solution was to download the latest stable version of LibreOffice from http://www.libreoffice.org/download/l... , and LibreOffice now runs great:-)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-05 18:03:33 +0200

Seen: 3,931 times

Last updated: Jul 19 '14