Ask Your Question
1

restarting figure numbers in master documents [closed]

asked 2014-05-05 21:14:06 +0200

PhiJ gravatar image

updated 2014-05-06 00:04:52 +0200

I've got a master document. Every chapter is a sub-document (and there are some other small subdocuments as well). Every chapter except the first starts with the style "Heading 2". I want the figure numbers (and table/'text' numbers for that matter) to restart for every new sub-document.

If I go to a subdocument (ch 6), set outline numbering level 1 to "Heading 2", save, and then update the master document... It works (I've set the figures to numbering by chapter level1, for the time being, in the master document, outline numbering starts with heading 2). The figure numbers restart at the beginning of chapter six.

If I do the same thing with the next chapter (ch7), that chapters figure numbering is correct, but the numbering from the previous chapter (ch6) has gone wrong again. When I updated chapter 7 it was as if I'd told chapter 6 to not restart the figure numbers.

Messing around shows that the figure numbering restarts for the last chapter I've updated and that chapter only.

Of course I want figure numbering restarted at the beginning of chapter 6 and chapter 7 and all of the other chapters. I can't see any way of doing this except doing all the figure numbers manually (I can't even hack the document as it's a master and doesn't store all the data). And I don't want manual figure numbers - that's a nightmare.

So can anybody help me fix the problem?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-21 21:16:56.816670

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-06 04:14:36 +0200

Rugslug gravatar image

Make sure your master document and sub docs use the headings the same way for outline numbering (and formatting etc). For future chapters, use a template to create new sub docs. When all files have the same formatting, things work much better.

I have sub docs where the tables et al are labelled 8.1, 8.2, etc.They are reset with each chapter. It can be set by clicking in front of the table number (or illustration or drawing # - each has to be done separately), then edit menu, Fields, Numbering By Chapter, set to level 1 (or level 2 in your case).

To do this in the master document (I found I had to set the master document table numbering the same way), in navigator right click on the first file name, Edit Link. De-select Protected under Write Protection. Again, in front of a table number (or illustration # etc), Edit Menu, Fields, Numbering by Chapter. OK out. Reset the Write Protection back to Protected. Right click on any file name in the navigator, and Update All.

I'm not sure this is your solution, but is worth a shot.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-05 21:14:06 +0200

Seen: 1,249 times

Last updated: May 06 '14