We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
-3

Why is Libreoffice automatically inserting styles into my document? WTF... who thought this was a good idea. I need to know how to get it to stop. [closed]

asked 2014-05-14 20:33:40 +0200

relogi gravatar image

updated 2021-05-27 21:27:51 +0200

Alex Kemp gravatar image

writer english libreoffice Version: 4.2.3.3

i defined two styles for my document... i amended default for font and paragraph handling.... i defined a chapter style based on default. Where the hell is First Line Indent coming from. And Text Body. Libreoffice wont let me delete the styles.... this is the kind of default behavior i would expect from a MicroSoft product. i admit I am unreasonable aggravated... but seriously, how do i make it stop?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-22 16:43:06.322977

Comments

1

Maybe you are saving the files in a non native format, so it's needed to adapt data format and styles to those file format.

m.a.riosv gravatar imagem.a.riosv ( 2014-05-14 21:49:01 +0200 )edit

You nailed it. Many thanks for intelligently answering an overwrought, underserving me. I will work on my posting manners in the future. FYI: i was actually saving in .ott at the time. The culprit was an icon for navigating the document that i copied from a file that was saved in .odt format, but at some time in the past had been saved in .doc. I blamed the program for the behavior because there was no direct link to MS nastiness. Why doesn't LO override the style when I ask it to?

relogi gravatar imagerelogi ( 2014-05-15 18:18:22 +0200 )edit

Please, can you report the bug, attaching a sample file where to reproduce the issue, Bug Submission Assistant. Once done, please inform here the bug number fdo@nnnnn. Would be nice if you look first if there is one similar in the list of bugs about Styles in Writer Bug about Style in Writer

m.a.riosv gravatar imagem.a.riosv ( 2014-05-16 00:19:54 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-05-14 22:03:10 +0200

mahfiaz gravatar image

These are the default styles. No, you cannot delete default styles (although you can hide them). These are included to the document only if they are used at least once. If you dislike these, you could choose from the styles dialog, that you want to see only "Customized" styles (or applied styles, whatever you fancy).

edit flag offensive delete link more

Comments

mahfiaz....this answer was no help at all... but perhaps i deserved it for (being an idiot) not appearing to be a decade long user of 1st openoffice and now libreoffice. the issue as i see it really is that libreoffice will not over ride the imported style's behavior in an intuitive, consistent fashion. but thanks for at least posting to what appeared to be a rtfm nutcase.

relogi gravatar imagerelogi ( 2014-05-15 18:26:11 +0200 )edit

Sorry for being harsh. You provided very little useful information about the actual problem, so this was the best I came up with. Luckily mariosv seems to be better seasoned by strange problems :)

mahfiaz gravatar imagemahfiaz ( 2014-05-15 20:44:17 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-14 20:33:40 +0200

Seen: 300 times

Last updated: May 14 '14