Ask Your Question
0

non-unity based menu in Ubuntu [closed]

asked 2014-05-16 12:04:25 +0200

Ljiljan gravatar image

updated 2015-09-06 10:14:20 +0200

Alex Kemp gravatar image

Last days I was experimenting with many different solutions regarding menu integration of LibreOffice in Unity, Ubuntu 14.04. Is there any simple solution not to have Unity menu integration, but just regular menu (as when installed from official web site) but without removing GNOME and GKT+ integration package (LO becomes ugly)?

Currently I am experiencing this bug ( http://www.youtube.com/watch?v=dabnfd... ) as well as menu being disabled even though they should not be disabled. I am pretty sure it is Unity problem (but it could because by wrong code in LibreOffice) because under under user interfaces this problem does not exist. I will upload video of this second problem as well.

So my question is: How to keep GKT+ and GNOME integration of Libreoffice in Unity, but to exclude Unity menu integration?

POSSIBLE SOLUTIONS: Remove LibreOffice and install it from official web site (DEB files). However by doing so, some problem appears regarding program icons on launcher (they are all grouped as one icon) and some dialogs are not nice as when they are installed via Ubuntu Software Center.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2016-02-23 12:02:37.983053

Comments

They won't even bother to answer. Probably they will classify my question as "subjective" or "already answer". But, the problem is evident and nobody is trying to solve it.

Ljiljan gravatar imageLjiljan ( 2014-05-16 19:29:59 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-05-23 12:46:10 +0200

Please try LibreOffice version 1:4.2.4~rc2-0ubuntu1~trusty3 from the PPA at https://launchpad.net/~libreoffice/+a... -- it should fix https://bugs.launchpad.net/ubuntu/+so... .

edit flag offensive delete link more

Comments

I installed newest version, but it didn't fix my problem ( http://www.youtube.com/watch?v=dabnfd... ). What I have discovered: if I have LO Quickstarter enabled, this problem appears when starting LO. However, when LO Quickstarted is disabled this problem does not appear when starting any LO program (for example Writer), but appears when I start another (Calc or Impress). Could this be of any help?

Ljiljan gravatar imageLjiljan ( 2014-05-24 11:48:48 +0200 )edit

If the problem persists please write a proper bug report (for unity integration best on launchpad) including a well defined reproduction scenario.

bjoern-michaelsen gravatar imagebjoern-michaelsen ( 2014-08-20 16:29:12 +0200 )edit

Ok. I reported the bug here https://bugs.launchpad.net/unity/+bug...

Ljiljan gravatar imageLjiljan ( 2014-08-22 08:34:32 +0200 )edit
0

answered 2014-05-16 14:10:38 +0200

mahfiaz gravatar image

You could disable the unity menu entirely: http://lifehacker.com/5887462/how-to-...

edit flag offensive delete link more

Comments

I tried this as well http://www.webupd8.org/2013/11/unity-... However, for every other application it works, but not for libreoffice :) I typed in blacklist ['libreoffice','libreoffice-writer'] any idea why?

Ljiljan gravatar imageLjiljan ( 2014-05-16 19:28:58 +0200 )edit

I believe you should type "soffice" there.

mahfiaz gravatar imagemahfiaz ( 2014-05-16 23:43:00 +0200 )edit

No, it does not work: "soffice" and "soffice.bin"

Ljiljan gravatar imageLjiljan ( 2014-05-17 09:11:53 +0200 )edit

Unfortunately I'm out of ideas then.

mahfiaz gravatar imagemahfiaz ( 2014-05-17 09:23:44 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-16 12:04:25 +0200

Seen: 544 times

Last updated: May 23 '14