Ask Your Question
0

Open Word Doc (from Mac) in Writer and every paragraph is now on a separate page? [closed]

asked 2014-06-03 01:00:28 +0200

TheCultOfKaos gravatar image

updated 2015-09-05 15:14:59 +0200

Alex Kemp gravatar image

My wife is working on her novels using writer on a windows 8.1 system. Her editor is using word for osx, using tracked changes and comments. When my wife received edits back from her somehow the formatting is all lost when opening in writer.

If I open the file in word natively (on my work laptop), it works fine.

It is docx formatted.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-24 14:00:18.484187

Comments

There is/was a known bug with comments and tracked changes being lost when roundtripping between docx and odt.

Alex Thurgood gravatar imageAlex Thurgood ( 2014-06-28 23:59:21 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-06-03 16:02:44 +0200

CyanCG gravatar image

There are a few key stylistic changes which might solve the paragraph display problem.

It always helps to display invisible characters: the menu item to toggle that is ViewNonprinting Characters. Then, do you see paragraph marks between the paragraphs, or do you see page break marks? If you see the latter, then it probably means that all paragraphs have a page break as part of their applied style.

Now, the question becomes: has styling been applied consistently? If formatting has been applied manually and by multiple people, then probably not. However, most paragraphs should have the same base style, either Default, Body text, Normal or something like that. In order to know which style is applied to a paragraph, first display the Styles and formatting window by toggling the menu item FormatStyles and Formatting. You can anchor this window to the side (I highly recommend doing so and developing a habit of using it for literally every formatting-related task). Now, when you put the text cursor in a paragraph, that paragraph’s style will be highlighted in the Styles and Formatting window. This allows you to know which style you need to change.

Right-click the appropriate style’s name, then click Modify…. In the dialog box, go to the Text flow tab. There, under the Breaks heading, if the Insert box is checked, you have found the culprit. Uncheck the box and all paragraphs with this base style should now display normally, with natural breaks occurring at the bottom of the pages’ display areas.

Keep in mind that paragraphs might have manual formatting applied on top of the base style. If that is the case, even unchecking the break box in the style will not remove breaks if breaks were applied manually (Microsoft Word does such ridiculous things all the time, so it would not be surprising). The radical solution is to select all such paragraphs and choose the menu item FormatClear Direct Formatting. This is a good cure. If any other manual formatting was applied, it will be lost as well, but in any case the formatting should always be applied by creating named styles in the Styles and Formatting window.

Hope this helps!

edit flag offensive delete link more
0

answered 2014-06-03 05:27:57 +0200

ROSt52 gravatar image

updated 2014-06-03 12:26:17 +0200

So far I experienced quite some format losses with all docx and other x-files. If you add Mac word, thinks can go worse. However I received recently a long docx-file which was assemble on a mixture of Macs and W7 (?) W8 (?) machines. I did not see that paragraphs turned pages.

Which version of LibO is used? 4.2.4. is available and I used this version to open the aforementioned file.

And what is the exact way the docx-file was opened? Where was the file located when it was opened?

A workaround could be to ask the editor to provide the feedback in the old doc-format.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-06-03 01:00:28 +0200

Seen: 382 times

Last updated: Jun 03 '14