Ask Your Question
0

Size and clipping problems with inserted odg file

asked 2014-06-18 10:48:30 +0200

Luc Mareau gravatar image

updated 2015-08-28 13:28:12 +0200

Alex Kemp gravatar image

Hello,

I created a drawing with LibreOffice Draw, which uses the entire page (portrait mode). Saved it and import it into a Writer document:

Insert -> Object -> OLE Object... -> Create from File - select created odg file - check "Link to File"

The image appears with some unwanted behaviour:

  • The odg object is not simply the page from Draw, where i painted my drawing on, but is much wider - about double as wide as the actual drawing (double as wide as the page in Draw). This means the inserted drawing is much smaller than it could be, as it only takes 50% of the page widht in Writer. And because the object width is limited to the page size in Writer, i can't enlarge the inserted drawing that the actual drawing width fits the page size in Writer. So how can i make LibreOffice to generate an odg object that contains only the page and no surrounding space?

  • The inserted drawing is clipped at the top or bottom, it does not contain the whole drawing. It seems the clipping correlates to the zoomed area in Draw, when the drawing was saved - when i zoom into the drawing in Draw and save it, only the zoomed area appears in the inserted odg object in Writer. When i zoom to the whole page in Draw and save the file, the inserted object contains the whole drawing (but not always). Is there a way to zoom the inserted object in Writer, that the complete drawing becomes visible?

I don't know if these are bugs or if there are some features not known to me...

Version: 4.2.3.3 OS: Kubuntu 14.04

Luc

edit retag flag offensive close merge delete

Comments

Duplicate of this question.

oweng gravatar imageoweng ( 2015-03-25 07:32:17 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2014-06-18 22:13:02 +0200

Regina gravatar image

An OLE has an object mode with green handles (single click) and an edit mode with gray border and black handles (double click). The object mode is only a projection of the true OLE.

When you want to change the shown section for an already inserted Draw OLE object, bring the OLE into edit mode and resize and position it there. If you will drag the green handles from the object mode, you only resize the projection of the OLE object.

Setting zoom in Draw has no effect on the OLE. The OLE is always shown in 100%. But the projection (green handles!) might be scaled down, if it is wider than the page width of the Writer document. To have a better control of the scaling factor you should use a window in Draw, that is smaller than the Writer document width, when you create your drawing in Draw. Then you will get a 100% picture in Writer and can scale it in the position&size dialog (green handles!).

edit flag offensive delete link more
0

answered 2015-03-25 07:29:46 +0200

oweng gravatar image

Refer the answer here.

edit flag offensive delete link more
0

answered 2015-03-25 06:15:12 +0200

ptm gravatar image

I've been having a similar problem on MAC OS X.

To insert a pdf into Writer, I first opened it into Draw. From Writer I used Insert / OLE Object / Create From File / *.odg. However the inserted object was not the same size as the page in the .odg file. It was not possible to crop the object, and moving the handles only changed the scale of the wrongly sized image, so this was no good.

I solved the problem by shrinking the viewing area in the Draw application to exactly the size of the page, and then saving this.

On insertion, the object in Writer was now the correct size.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-06-18 10:48:30 +0200

Seen: 1,808 times

Last updated: Mar 25 '15