Ask Your Question
0

Upgrade of Linux LibreOffice from 4.2.4 to 4.2.5 fails [closed]

asked 2014-06-30 17:55:47 +0100

trickyHarry gravatar image

updated 2015-09-02 22:42:14 +0100

Alex Kemp gravatar image

Dear All, I have a problem with LibreOffice v4.2.4 not being able to upgrade to 4.2.5. Unless I am doing something wrong or missing something.
I have the following packages installed :-
a. The base LibreOffice v4.2.4
b. The GB Language interface for v4.2.4
c. The off-line help for v4.2.4

It seems that when I am attempting to install the v4.2.4 base, I still have dependancies on the GB Language modules that require the older version that I am removing ....
= Any suggestions on a work-around for this going forward ??

I am using Fedora 20 with 4.2.4 currently installed ...

---> Package libobasis4.2-core01.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core02.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core02.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core03.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core03.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core04.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core04.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core05.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core05.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core06.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core06.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-core07.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-core07.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-draw.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-draw.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US-base.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US-base.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US-calc.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US-calc.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US-math.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US-math.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US-res.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US-res.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-en-US-writer.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-en-US-writer.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-extension-beanshell-script-provider.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-extension-beanshell-script-provider.x86_64 0:4.2.5.2-2 will be an update
---> Package libobasis4.2-extension-javascript-script-provider.x86_64 0:4.2.4.2-2 will be updated
---> Package libobasis4.2-extension-javascript-script-provider.x86_64 0:4.2.5.2-2 will be an update
---> Package ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-27 10:48:13.970889

1 Answer

Sort by » oldest newest most voted
0

answered 2014-06-30 18:16:01 +0100

trickyHarry gravatar image

updated 2014-06-30 18:26:05 +0100

I believe that I can suggest an interim solution :- a. The Additional Language packs have a depenancy on the base install and will prevent an upgrade. Instead of removing all of LibreOffice base & Language packs, remove the smaller language pack and then upgrade the base b. Then add the latest language pack c. Add the off-line help - and install that rpm also .. - The help rpm can be added to the custom language interface for simpler installation ...

To get the language pack [I am using the UK English or 'GB' ]

rpm -qa | grep libre | grep GB > GB_files
rpm -qa | grep libobasis | grep GB >> GB_files
yum erase $( cat GB_files )

cd xxx/v4.2.5/LibreOffice_4.x.y.z_Linux_x86-64_rpm/RPMS
yum update ./*.rpm

cd ../../*_langpack_en-GB/RPMS/
yum install *.rpm

cd ../../*_help
yum install ./*.rpm
edit flag offensive delete link more

Comments

The command lines seem to be meshed together, I am sorry. I should have paid more attention to the formatting to make it easier to read.

trickyHarry gravatar imagetrickyHarry ( 2014-06-30 18:19:08 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-06-30 17:55:47 +0100

Seen: 309 times

Last updated: Jun 30 '14