Ask Your Question
0

Can not change default font color [closed]

asked 2014-07-17 18:46:20 +0200

SteveH_66 gravatar image

updated 2015-08-31 22:54:49 +0200

Alex Kemp gravatar image

I just reinstalled windows 7, and reinstalled LibreOffice with the latest version (4.2.5.2) and I am unable to change the default font color. I went into tools>options>appearance and changed background color to black, font color to blue 4 (I do not like black text on white background, causes eye strain for me). Clicked OK. The background color changed to black, as it was supposed to. The font is showing up as white. If I change it on the color button drop down list on the toolbar to blue 4, it changes just fine. When I go to styles and formatting, right click on Default Style and go to the font tab, it shows that the font color is blue in the sample text box. But I have to change it with the drop down button list, the font color is white even though the default is set to blue 4. I believe this is a bug. Am I incorrect, and if not a bug how do I get the default font color change to work? Thanks

Note : It does let me change the default color to blue and that takes. Looking more like a bug.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 23:41:39.653329

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-18 04:11:52 +0200

oweng gravatar image

updated 2014-07-18 04:52:06 +0200

Confirmed under GNU/Linux with v3.5.7.2, v4.1.6.2, v4.2.5.2, and v4.3.0.2. It may be an Accessibility bug in that LO is overriding the font colour because it believes the contrast is insufficient. Tools > Options... > Accessibility > Options for high contrast appearance section > the first two options are unchecked by default, but they should only apply (when checked) to system themes in any case. Given a default (or non-high contrast) O/S theme the LO settings should be respected. I will report a bug. Related bug is fdo#81477.

Workaround: Find a font colour that is not quite so dark. On a black background setting the font color "Blue 2" appears to be the darkest blue that displays as expected.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-07-17 18:46:20 +0200

Seen: 1,571 times

Last updated: Jul 18 '14