Ask Your Question
0

Writer: Paragraph style does not apply font type and size [closed]

asked 2014-07-21 15:47:53 +0200

Learner gravatar image

updated 2015-08-31 21:14:13 +0200

Alex Kemp gravatar image

Libreoffice 4.2 4.2 / Linux Ubuntu 14.04 / English

Hi, I have defined a new paragraph style (called "AQuote"), with the following settings (I mention only the ones I changed):

Organizer:

            Next Style: Default Style
            Linked with: Default Style
            Category: Text Styles
            [this one forced by the program: I selected Custom but it turned to Text Styles
             when I opened it again in Modify mode from Styles and Formatting]

Indents & Spacing:

            Before text: 1.20 cm
            Above paragraph: 0.70 cm
            Below paragraph: 0.70 cm
            Checked: Don't add space between paragraphs of the same style

Font:

            Gentium
            10 pt

My Default style uses URW Palladio L 12 pt. A typical instance of my prob is the following:

I type one or more paragraphs in Default Style. Then I select the paragraphs and double click AQuote (either in the Styles and Formatting window or in the dropdown menu). The paragraph formatting (indents and spaces) is applied to the selected text but the font formatting (font type and size) is not.

I have found out an untidy workaround. If I define a new character style (which I also called "AQuote" in the faint hope it would be applied automatically) with the same font specs as the paragraph style and apply it to the text previously formatted, the font formatting is correctly applied (preserving bold and italics). But this looks like a poor solution, sort of slapdash. Moreover, it seems to behave erratically: if instead of making new styles I just change the (standard) Paragraph Quotations and the Character Quotation ones, the program behaves in the same way as above but my workaround does not preserve bold and italics.

(Now, this might be OT or maybe not.) An additional weird behaviour of the program is that if I move the cursor to the end of the newly formatted text and press Enter, the new paragraph I get is in Default Style (I set Next Style = Default in Organizer) but with Gentium 10 pt font (visible pressing CTRL-F10). If I press Enter again, without entering any text, the new paragraph is still Default Style and Gentium 10, but the previous one turns to URW Palladio 12 pt -- provided I didn't enter any text in it. Just so: the paragraph sign on the line above the cursor suddenly grows to 12 pts and its font switches to URWPalladio.

Maybe I'm just missing some basic feature of the way Writer handles styles and formatting; but I have searched the web for several days before posting this and I am a bit puzzled. Thanks to anyone who would help! -- and many thanks to the people who have written Libreoffice.

EDIT:: mariosv's suggestion of resetting the user profile works, so far as the question is concerned: font type and size are correctly applied to chunks of text typed in in Default Style. They are not consistently applied to chunks of text copied and pasted from other documents -- but these might have been ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-01 01:10:34.720098

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-22 00:07:14 +0200

m.a.riosv gravatar image

Try doing a Ctrl-M (clear direct formatting), I think direct format has precedence over Font style and this over Paragraph style.
If it doesn't solve the issue you can try resetting the user profile Resetting user profile

edit flag offensive delete link more

Comments

In addition to what @mariosv has mentioned, be sure the name of the font "Gentium" matches the name of the font installed on the system. I have some some old documents here that use "Gentium" but SIL renamed this font at some point to "Gentium Book" or "Gentium Plus" (which is now the currently installed font I use). The result is the font in these old documents is no longer applied correctly.

oweng gravatar imageoweng ( 2014-07-22 01:39:40 +0200 )edit

@mariosv Thank you. I already tried CTRL-M and I know it works, but it also removes italics, which is very inconvenient to me. The known workaround is even less convenient than mine above... I'd like to say: at any rate, the fact that the CTRL-M solution allows the paragraph style to properly work is a symptom of a sort of problem because no direct formatting about font type and size was there, yet the change in style failed to affect it.

Learner gravatar imageLearner ( 2014-07-22 09:38:59 +0200 )edit

@oweng I checked and changed the font (Ubuntu font), then made more versions of my style with different fonts but they didn't work -- they behaved the same way. I thought, I can surely make my quotes in the same font type and size as the default text and just some indentation, which would save me lots of trouble. But you know, I have sniffed a problem here and will not be content until I can dispel some of the fog about it. (Old habit of an old programmer.)

Learner gravatar imageLearner ( 2014-07-22 09:46:08 +0200 )edit
1

@mariosv Resetting the user profile did it. I still have some trouble with erratic program behaviour about preserving italics, but that is another matter. I have edited the original question to add some comments about this. Thank you!

Learner gravatar imageLearner ( 2014-07-22 12:08:57 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-21 15:47:53 +0200

Seen: 2,910 times

Last updated: Jul 22 '14