Ask Your Question
4

Read only content cannot be changed, no modifications will be accepted

asked 2014-08-06 10:59:22 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tried going into Options, Writer, Formating Aids and unticking Cursor in Protected Areas.

I have seen so many posts about this but never see a successful solution. Its a very comment problem. Please can this get solved. I want to recommend that my customers change to LibreOffice but how can I when a problem as big as this exsists.

I am using 4.3.0.4, On Windows 8.1

edit retag flag offensive close merge delete

Comments

@"Nick Halliwell": You posted a question and updated it stressing it's urgency. There were three answers meanwhile. Would you be so kind to tell us which answer met (part of) your question - or in which way the contributors may have misunderstood it? It should also be helpful to get linked here some of the "many posts about this". you have seen to better understand the problem.

Lupp gravatar imageLupp ( 2014-08-20 20:07:04 +0100 )edit

Lupp, the title of the post "Read only content cannot be changed. No modifications will be accepted." is the exact text of the error dialog. It has nothing to do with write-protected files, email attachments stored in /tmp, and the only "solution" out there is to delete the "protected" text. It is a known bug since 2011

http://en.libreofficeforum.org/node/7289

and the correct answer to this post is "this is a known bug since 2011 and it is still marked as "NEW".

I have the same issue.

jerquee gravatar imagejerquee ( 2014-10-16 23:05:51 +0100 )edit

I never had experienced that specific problem - and therefore had another notion of the subject's meaning. The topic in libreofficeforum you linked in is containing one link to a bug report from 2013-06-19. It also contains an attached example which is showing for me the "fieldmark highlighting" contributors tak about but the text contained is editable for me with Writer V4.3.2 under Win 8.1 (alas!). Nonetheless we have clearly a (complicated?) bug.

Lupp gravatar imageLupp ( 2014-10-16 23:55:53 +0100 )edit

"... It has nothing to do with write-protected files, ... " It might have to do with the history of the document and its former states as a file stored and loaded by whatever software with whatever filters in whatever formats.

....

Just inspected the content.xml out of the above mentioned example. The problematic fields were fragmented in a ridiculous way. Don't think that can be the result of a curriculum vitae under the rule of odf.

Lupp gravatar imageLupp ( 2014-10-17 00:18:51 +0100 )edit
cement_head gravatar imagecement_head ( 2016-02-24 20:04:58 +0100 )edit

Got here because of also getting the "Write-protected content cannot be changed." message and searching for answers. In my case saved original document as *.doc (97-2003), lost some Form Controls (Radio Buttons, List Box) in the process. Later Saved As *.odt to fix document and re-do the Controls. Check Boxes changed to grey, could not delete them, got above message. Read this post, selected one character before and one after Check Box, then deleted it successfuly! Thanks for the help.

Petr_Libre gravatar imagePetr_Libre ( 2016-06-23 20:51:04 +0100 )edit

16 Answers

Sort by » oldest newest most voted
0

answered 2016-08-11 14:01:27 +0100

This is what worked for me (tried the "clip from one char before..." suggestion above but that just refused me as well) :-

  1. Re-SAVE the document from Libreoffice in the "OPENOFFICE DOCX" format (the one right down at the bottom of the format selector - NOT Windows DOCX) ;

  2. The close and Open the resulting document anew: the locked section is now unlocked.

Small disruption to some centring but nothing problematic.

Good luck all

edit flag offensive delete link more
0

answered 2016-10-22 02:12:23 +0100

I see that this has been a problem for some time. I have a document that was created in MS Office. It has a table in it. A very simple table. I can open the document in MS Office and fill in the table. I can open the document in OpenOffice and fill in the table. When I open the document in LibreOffice, it claims that the cells cannot be written into and there is no way to change that. I have tried everything I have read here and elsewhere. LibreOffice is treating the table incorrectly and, as a result, this form and others like it cannot be used in LibreOffice. If anybody has a way to fix this (and I am starting to doubt that there is a fix given the back-and-forthing) I would appreciate having somebody tell me what it is. And I will tell you up front that the solutions which center on unprotecting the cells do not work because apparently LibreOffice, while it says the cells cannot be written into, does not have an option to kill the protection. In fact, there is no option presented no matter how much I right click.

edit flag offensive delete link more
0

answered 2018-01-23 18:59:13 +0100

updated 2018-01-23 18:59:49 +0100

Got this error message in LO 5.4.2.2 in Ubuntu 17.04. In my case, it also said "read only" in the status bar at the bottom of the screen.

Solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

All other solutions failed for me.

edit flag offensive delete link more

Comments

I had the same error in a document converted from Word. This was the only solution that worked for me too.

bartovan gravatar imagebartovan ( 2018-08-12 12:41:20 +0100 )edit
0

answered 2014-08-06 11:40:29 +0100

Pedro gravatar image

If the document is set as Read Only that is probably because you opened it directly from an email attachment (and therefore it is stored in a Temporary folder, where you don't want it to be). The proper way to edit a document is to Save the attached file to some organized folder you own and then Open the document for Editing.

Another important reminder: NEVER get an x.x.0 version. It will (most probably) have bugs and regressions. You should get the version with the highest 3rd digit (currently 4.2.6)

Example: in the Download page (at the very bottom) you will see

LibreOffice is available in the following released version

4.1.6
4.2.5
4.2.6
4.3.0

You should get either version 4.2.6 or 4.1.6 (older, with less features which you might or not need, but equally bug free)

Recommending any other version to your customers is doing a bad service to them, to the project and especially to yourself (because, as usual, if you recommend anything, any problem in the software is your fault and people expect YOU to fix it :) )

edit flag offensive delete link more
0

answered 2020-09-22 20:13:14 +0100

updated 2020-09-22 20:17:20 +0100

I found a solution for this problem. This happened to a particular cell while I was editing a table. I could get rid of it changing the size of the cell. I grabbed the top edge of the cell and dragged it down, and then I could edit it again. I don't know if it will work for you, but it did for me. Nothing else did work, except for changing the size of the cell. I hope it works for you too. OBS. This happened between one page and another. I dragged the top edge down until the cell dropped to the next page.

edit flag offensive delete link more
0

answered 2019-12-20 05:43:40 +0100

On the mac, you will find "protected form" under menu: LibreOffice -> Preferences -> LibreOffice Writer -> Compatibility uncheck "protected form" and you should be able to work on the document again.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

5 followers

Stats

Asked: 2014-08-06 10:59:22 +0100

Seen: 61,471 times

Last updated: Sep 22