Ask Your Question
0

Base 4.3.0 change - Form combo box no longer works as expected. [closed]

asked 2014-08-08 01:06:26 +0100

JohnD gravatar image

Upgraded to 4.3.0 from 4.2.6. Previously when typing into a combo box in a Base form the entry would automatically show possible entries from the database field to select. Now in version 4.3.0 it no longer does that - the down arrow must be clicked to see possible entries.

Has a change been made? New option someplace? Possible regression error?

Thanks,

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by JohnD
close date 2014-09-01 00:44:16.907980

Comments

stepped into Base for first time at 4.3, figured the combo box always had been broken. While it is being fixed, consider using ListBox instead with a dropdown menu. Very similar functionality, working well enough for me.

doug gravatar imagedoug ( 2014-08-08 05:13:07 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-08-16 07:32:50 +0100

JohnD gravatar image

I filed a bug report and provided a small test file for this and received some excellent help resolving my issue.

Combobox changed, you are right. But combobox does now, what it should do: Open the form for editing. Have a look at the general properties of the comboboxes. Only the combobox for text is set to "AutoFill"→"No" (and also "Hide Selection"→"No"). I don't know why it works with AutoFill in LO 4.2.6.2, but it doesn't in 4.3.0.4, because it is set to "No". Set "AutoFill" to "Yes" and it works.

Robert - Thank you very much! I completely missed those settings (probably because they were not effective in previous versions - good excuse, huh? :)

I am changing the status to Resolved - Not a Bug.

John D

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-08-08 01:06:26 +0100

Seen: 412 times

Last updated: Aug 16 '14