Ask Your Question
1

How can I auto-insert vowels with macrons using autocorrect [closed]

asked 2014-08-12 09:06:52 +0200

gojoppari gravatar image

updated 2016-03-02 00:10:50 +0200

Alex Kemp gravatar image

OSX10.9.4 LibreOffice 4.3.0.4 (Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0)

I use macrons frequently in my writing. I have always used a custom autocorrect shortcut in Word. Usually:

  • ;a; = ā
  • ;e; = ē etc.

With LO, I have tried this pattern as well as the following:

  • ;;a
  • /a/
  • //a
  • aaa

None of these autocorrect formulas works. Autocorrect is functioning correctly, however, with English. Example: wokr = work

What can I do? This is a complete dealbreaker for me as much as I like LO otherwise.

Thank you in advance for any advice

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-02 00:11:04.054413

2 Answers

Sort by » oldest newest most voted
2

answered 2014-08-12 13:49:15 +0200

ROSt52 gravatar image

You might not have set all parameters.

Tools > AutoCorrect Options > Replace: enter your characters and on the very top of this window you must select the language you are using in your document

and

Format > AutoCorrect > While Typing must be selected

edit flag offensive delete link more

Comments

The language for the document (paragraph being typed in) and that set on the AutoCorrect dialog (where the replacement combination is added) must also match. Replacement entry of ;a; with ā works here for me under GNU/Linux using v4.3.0.4 (en-AU).

oweng gravatar imageoweng ( 2014-08-12 17:19:25 +0200 )edit

Thank you both. Don't have enough pts to upvote, but the trick was to select American English when creating the autocorrect options, not all languages -- as oweng suggested.

Very grateful.

gojoppari gravatar imagegojoppari ( 2014-08-12 22:23:29 +0200 )edit

Thanks for confirming. You should have enough karma now.

oweng gravatar imageoweng ( 2014-08-13 02:51:33 +0200 )edit

Hmm... I spoke too soon.

LibreOffice can convert letters when they are isolated as words, i.e. with spaces on either sides, but can't make the change in mid-word.

For example: ;o; = ō T;o;hoku = no change

This doesn't really solve the problem after all, which is quite disappointing.

Your further help would be greatly appreciated.

gojoppari gravatar imagegojoppari ( 2014-08-13 11:36:47 +0200 )edit
1

You may try the extension ComposeSpecialCharacters as an alternative, see
LO writer: insert special characters by shortcut keys
Special characters · Part II.

E.g.: ...o-<Alt+F8>... = ...ō...

manj_k gravatar imagemanj_k ( 2014-08-13 14:02:40 +0200 )edit

It took a lot of fiddling around, but I finally got CSC to work. The trick was not to use the CSC dialog to set the key combination. Instead, I went directly to the Tools > Customize > Keyboard > LibreOffice Macros > user > ComposeSpecialChars > ModCode > ComposeSpecialChar and assigned a shortcut from there. I also learned the hard way that combinations with Shift are fraught. For example, LO treats ⌘-Shift-Q the same as ⌘-Q. So be careful. Thank you all for your patience and expertise!

gojoppari gravatar imagegojoppari ( 2014-08-13 23:59:34 +0200 )edit
0

answered 2014-08-13 15:59:18 +0200

oweng gravatar image

Hmm... I spoke too soon. LibreOffice can convert letters when they are isolated as words, i.e. with spaces on either sides, but can't make the change in mid-word.

For example: ;o; = ō T;o;hoku = no change

Support for wildcard AutoCorrect entries is coming in v4.4 (currently only in alpha dev-builds of v4.4.0.0) and will hopefully be backported to the v4.3 series. A rule entry like .*;a;.* to ā will allow for any-context replacement of the type indicated. Refer fdo#55292.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-08-12 09:06:52 +0200

Seen: 899 times

Last updated: Aug 13 '14