We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

how do I get my index to be listed in my table of contents? [closed]

asked 2014-08-27 00:06:16 +0200

reese.holser gravatar image

updated 2020-07-27 17:41:47 +0200

Alex Kemp gravatar image

I am using Version: Build ID: 420m0(Build:2) (the English version) of LibreOffice Writer.
The operating system I am using is Kubuntu-14.04-desktop-AMD64.iso

I have a 436 page book I am working on. The index is fine. The table of contents is also fine except that the index with its page number is not listed at the bottom. I normally add items to the table of contents by highlighting the text I want to add, then I change the style to heading 1, heading 2, etc. in the text box at the left side of the formatting toolbar which is towards the top of the window. However, I can't do anything to change the style of the word Index at the top of this index. I can't find anything on Google about this, or in https://help.libreoffice.org/ .

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 10:51:38.304975

2 Answers

Sort by » oldest newest most voted

answered 2014-08-27 08:34:15 +0200

ROSt52 gravatar image

I assume you followed the standard procedure of Writer when you created your Index entries and your Index table. If so then you can do:

  • Open the Styles and Formatting window (e.g via F11)
  • Click the tab paragraphs - this typically the default
  • Place the cursor in the title of your index table.
  • Look into the paragraph styles and now "Index Heading" should have a grey background
  • If you don't see any entry with a grey background go to the bottom of the window and select "All Styles"
    When have created your index table in the standard procedure you should now see "Index Heading" with a grey background
  • Right click > modify > font tab and change here the font etc you want to use
  • Click "Apply" and the "title line" of your index table will show the new font you selected.
  • Click "Save"

If this doesn't answer your question, please explain in details how you created your index table.

Two side notes: 1 -When you want to make a text line a heading 1,2,3, etc you do not need to select the entire line, you only need to place the cursor in this line and then do ctrl+1 or 2 or 3 etc and you created the heading 1, or 2, or 3, etc

2 - Make a daily backup of your book thus a loss is maximum 24 h of work And make sure a copy of the backup is on an external drive. Ideally have 2 external backups. Store one even outside your house. I did this with a similar work and then slept very well. (I added the side note 2 because very often the question "How can I get my file back..." appears in this forum.)

edit flag offensive delete link more

answered 2014-08-28 13:13:50 +0200

oweng gravatar image

As @ROSt52 indicates, by default an alphabetic index will be inserted with a title of "Alphabetic Index". This title will use the Index Heading paragraph style and appear with a grey background, in keeping with the rest of the alphabetic index. To including this title in the table of contents (ToC), which is also an index:

  1. Right-click on the ToC > Edit Index/Table...
  2. Index/Table tab > Create from section > check Additional Styles option > click ellipsis [...] button.
  3. Select Index Heading entry > click [·>|] button to set entry to level 1 > click OK.
edit flag offensive delete link more

Question Tools



Asked: 2014-08-27 00:06:16 +0200

Seen: 903 times

Last updated: Aug 28 '14