Ask Your Question
0

How to get rid of WW8Num8 list style [closed]

asked 2014-08-27 16:58:06 +0200

Alias duel zone gravatar image

updated 2016-03-03 10:35:13 +0200

Alex Kemp gravatar image

I'm working with:

LibreOffice     4.2.3.3
MacOS X         10.8.5

I got more than 20 list styles I don't use and I would like to remove. I want to get rid of menus jamed with useless entries.

These list styles have names of the form:

WW8Num<n>

where n is a number in [1 ; 25]. These styles are the results of a .doc opening.

When a select anyone of this list styles, let's say for example WW8Num8,

open the control drop down menu,

and select Delete..., the selected list style disappear from the displayed list.

But...

I have a problem.

  1. If I close and reopen Format > Styles and Formatting, the list style WW8Num8 is there again.
  2. If I am on a paragraph where this list style was used, this paragraph is still using the list style WW8Num8.

How may I get rid of (for example) the WW8Num8 list style?

Is this a bug?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 10:36:10.215663

Comments

→ oweng: I didn't find an answer to my question within this other question. I read it and understood it. This other question is asking why and received your correct explanation. Now my question is how to get rid ot these formats. I do have to get rid of them to be able to work on my document. I will stay on .odt format.

Alias duel zone gravatar imageAlias duel zone ( 2014-08-29 15:23:28 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-08-28 12:26:21 +0200

oweng gravatar image

updated 2014-08-30 05:36:48 +0200

Here is a clear outline of why this is happening and explicit steps on how to remove the unwanted list styles. The question is related to this one, which explains that the MS Binary (DOC) and OOXML (DOCX) file formats do not support list styles e.g.,

These styles are the results of a .doc opening.

This is a rough outline of the steps required to remove these styles:

  1. File > Save As... > select format of "ODF Text Document (.odt)" > click OK. This is necessary, otherwise these styles will keep coming back, because they are the result of ODF list styles being converted in the output filter.
  2. Close / re-open document (the newly saved ODT, not the DOC).
  3. Re-style all list text instances:

    1. If a custom list style definition is to be used, it is first necessary to define the required list style e.g., List 1 start at X (based on List 1 list style).
    2. Re-associate paragraph styles to list styles. In the Styles and Formatting panel > right-click on the required List N or Numbering N paragraph style > Modify... > Outline & Numbering tab > Numbering section > select the required Numbering Style (e.g., Numbering 1). Refer the answer here as to why this association between paragraph and list styles is important, especially for those wanting to make use of styles (rather than use direct formatting).
    3. Repeat step (3.1) for each required custom list style and step (3.2) for each paragraph style of a list type that is required to be used.
    4. Associate each instance of a list (and the list items, as required, refer this answer) with the appropriate paragraph style (not list style).
  4. Remove WWNumN list styles. As you indicate in the question, this can be done via right-click on the WWNumN list style > Delete.... If any of these styles are still in use, a dialog will display indicating this (after step (3) above these styles should not be used).

  5. Save the re-styled document (to ODT). Any re-save to a non-native format will undo all the above work.
edit flag offensive delete link more

Comments

Well presented & great answer :) !

Alias duel zone gravatar imageAlias duel zone ( 2014-08-30 16:43:00 +0200 )edit
0

answered 2014-08-27 18:18:40 +0200

petermau gravatar image

updated 2014-08-27 18:59:00 +0200

On my 4.3 and 4.2, Linux and Linux-Mint Mate systems, my list styles are LIST1 - LIST5 and Numbering1 - Numbering5, ten items in total. Have you created your styles such as WW8Num (1 - 25)? If you select APPLIED STYLES you will only see those styles you are actually using. CUSTOM STYLES will show up those you have created. If you have any documents using these styles, I understand they will show up.

Is this a document you have created on LibO using .odt format or have you imported it from some other format. Also it is useful to know your operating system. This may not actually answer your question but i hope it may give the odd clue.. Peter added to original answer =========

Well I assume that you have documents that actually use these List Styles, therefore they show up in the LIST STYLES. Does using the CUSTOM STYLES show up these styles? I assume choosing APPLIED STYLES will only list those styles you are using in that document. If you have LIST STYLES defined in existing documents, it is natural that they will show up on the STYLES pages.

edit flag offensive delete link more

Comments

I added these important details within my OQ.

Alias duel zone gravatar imageAlias duel zone ( 2014-08-27 18:33:59 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-27 16:58:06 +0200

Seen: 689 times

Last updated: Aug 30 '14