Ask Your Question
1

Greek letters in math formula have reverted to non-italic [closed]

asked 2012-07-18 10:20:56 +0200

jdpipe gravatar image

updated 2015-11-04 02:27:09 +0200

Alex Kemp gravatar image

Hi there

In previous versions of LibreOffice/OpenOffice (as of ~Jun 2011) provided a symbol catalog such that when using "%alpha" or "%rho" in a formula yielded an greek letter in italics. This is consistent with the styling used in most high-quality textbooks, Latex, etc and was a good default behaviour.

Now, for some reason, with LO 3.5.4.2 on Ubuntu 12.04, it appears that all math symbols are coming out in non-italics, which LOOKS TERRIBLE.

Because I have a large document that I've previously written, I need a way to change my math symbol catalog so that ALL greek letters are in italics.

Also, I need to change their font from "OpenSymbol" to "Liberation Serif", since the OpenSymbol typeface seems to be lacking some key metrics, since my "%alpha" character lacks correct baseline information, so the format of an equation like "1 over %alpha" looks all wrong.

Any suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-04 02:27:26.641069

Comments

1

@tohuwawohu: you can't set the font for Math formulas in this way for symbols like %alpha, %omega, etc, since the symbol catalog includes its own definitions of the font and style of special symbols, which overrides the main font definition. So unfortunately this doesn't help me (as far as I can tel

jdpipe gravatar imagejdpipe ( 2012-07-20 07:15:55 +0200 )edit

Oh, i see - you're right. Is this your bug report? I've just put myself on its CC list.

tohuwawohu gravatar imagetohuwawohu ( 2012-07-20 08:06:42 +0200 )edit

That's right, that's my bug report. No responses yet, but let's see

jdpipe gravatar imagejdpipe ( 2012-07-21 07:34:56 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-02-21 06:04:59 +0200

qubit gravatar image

This bug filed as fdo#52225 - Greek symbols have switched back to non-italic.

Current status of this bug: NEW

edit flag offensive delete link more

Comments

Current status: bug is RESOLVED FIXED.

jdpipe gravatar imagejdpipe ( 2018-07-03 04:20:58 +0200 )edit
0

answered 2015-09-03 19:12:27 +0200

Whether this worked or not in previous versions, I do not know, but in open office 4.1.1, you can make any greek letters italicized using the following notation:

ital %gamma

edit flag offensive delete link more

Comments

FWIW there is also '%igamma', '%itheta' etc for italics. But this is not helpful for fixing up large existing documents which previously rendered with italics (and non italics is not a good default for lower-case greek letters according to standard publishing practices)

jdpipe gravatar imagejdpipe ( 2015-09-28 02:41:10 +0200 )edit
0

answered 2012-07-18 10:37:57 +0200

tohuwawohu gravatar image

You can set the fonts to use in Math formulas using Menu "Format" -> "Fonts...".

edit flag offensive delete link more

Comments

This *doesn't* work for math symbols entered via the 'symbol macros' eg "%beta". That is because the symbol catalog specifies the font that is used for these catalog symbols. Terrible design fault in my view -- no way to change the font used for Greek symbols in a document en masse, makes for ugly documents. OpenSymbol is hard-wired into LibreOffice, and italic greek letters in OpenSymbol are ugly.

jdpipe gravatar imagejdpipe ( 2013-07-14 09:11:00 +0200 )edit
0

answered 2013-07-14 09:19:36 +0200

jdpipe gravatar image

updated 2013-07-23 02:02:08 +0200

I found a nice solution for this. On Ubuntu 12.04, I closed all of my LibreOffice windows, and edited the file ~/.config/libreoffice/4/user/registrymodifications.xcu. I searched for "Greek" and found the following line:

<item oor:path="/org.openoffice.Office.Math/StandardFormat"><prop oor:name="GreekCharStyle" oor:op="fuse"><value>1</value></prop></item>

The <value>1</value> was my edit; originally it showed "0" (non-italic, i.e. roman); I changed it to 1 (italics). You can also use 2 if you want italics for lower-case and non-italics for uppercase Greek letters (but I'm not sure that works as stated -- please test). After restarting LibreOffice, the desired behaviour will occur!

See here for the bug and original code commits relating to the above: https://issues.apache.org/ooo/show_bug.cgi?id=113276

Two issues:

  1. there is no quick way to force re-formatting of all your equations in the document, although you might be able to figure something out from https://wiki.documentfoundation.org/images/3/37/MG40-MathGuide.pdf#page=46
  2. there is still no easy way to quickly modify the Symbol Catalog to use a different font instead of OpenSymbol. This is still needed because the OpenSymbol font lacks correct font metrics, and results in poorly-formatted equations.
edit flag offensive delete link more

Comments

Update: as of LibreOffice 5.1.4.2, this workaround no longer works. The "/org.openoffice.Office.Math/StandardFormat" option seems to have been removed.

jdpipe gravatar imagejdpipe ( 2016-07-19 14:11:21 +0200 )edit

No this is still implemented. Access from Tools -> Options -> Advanced: Open Expert Configuration. Search for GreekCharStyle property and toggle from default "0" to "1" for all Greek symbols to render italic. Stanza will be written into registrymodifications.xcu per user--and active on relaunch of LibreOffice.

vsfoote gravatar imagevsfoote ( 2016-07-19 17:18:33 +0200 )edit

Working with setting GreekCharStyle property (5.2.0.2 and 5.3.0 master builds) verified that setting the "2" value renders StarMath lower case Greek symbols in italic, and upper case StarMath symbols as non-Italic, the LaTex norm. Applies to a new document--not clear if formulas in an existing document can be "converted"

vsfoote gravatar imagevsfoote ( 2016-07-19 18:20:44 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-07-18 10:20:56 +0200

Seen: 11,039 times

Last updated: Jul 23 '13