Ask Your Question
0

How to enable autorecovery ? [closed]

asked 2012-07-18 23:39:06 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I've just lost about 5 hours of hard work because my computer crashed and libreoffice did not saved autorecovery and did not ask to recover all the documents that were opened when the computer crashed.

I had set sabe autorecovery every 1 minute. But this does not work at all.

To make a test I opened a document, changed and did not save it. Then I xkill libreoffice and then opened the document again. Nothing happends. No ask for recovery. Never.

There is something wrong because It should ask if you left your document open when Libreoffice went down.

Sorry to say that, but I regret the day I changed from openoffice to libreoffice. This problem is very important. No one can survive with a office that does not save by itself the documents.

I use ubuntu 10.04 and LibreOffice 3.5.4.2

I need to find a way to make the autorecovery works. It seems like it is disabled in my system. I have another computer and it is working ok. After a xkill it tries to recover the previous opened documents.

Please, help me with this.

The auto recovery is set. But it does not work. Please dont respond saying to click at the checkbox at the menu. This is done. And this is very simple to do.

My problem is deep. This is not working. I need to find a way to work

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 23:10:31.827607

Comments

Correction: @ozp is the author of this question (initial version + revision).

manj_k gravatar imagemanj_k ( 2012-07-20 08:53:05 +0200 )edit

Backups path: just 1 file is saved there and update itself from minute to minute (I set auto save with 1 minute).

Temporary files: was set at /tmp I could not find any files there. I set to /home/ozp/ and then I see the temporary folder lua9jo37.tmp but empty!! No files inside

ozp gravatar imageozp ( 2012-07-21 02:23:34 +0200 )edit
1

Login in with another user autorecovery works. Must be some configuration that prevent libreoffice to save the recovery file

ozp gravatar imageozp ( 2012-07-21 19:53:02 +0200 )edit

Does AutoRecovery work for your first user with a LibreOffice default user profile? [Resetting the user profile]

manj_k gravatar imagemanj_k ( 2012-07-22 00:59:36 +0200 )edit

I think it does. I dont know how to reset user profile. I could delete all the folders inside my /home/user. but I fear to loose the gramar and dictionary files. But for other user at the same machine the autorecovery works. Must be some config. But I have no clue where to find it

ozp gravatar imageozp ( 2012-07-31 14:21:04 +0200 )edit

Have a look at the link in the comment above [July 22].

manj_k gravatar imagemanj_k ( 2012-08-01 23:11:03 +0200 )edit

Hi @ozp, Have you found a resolution for this problem? Please let us know if either of the answers below works for you. Thanks!

qubit gravatar imagequbit ( 2013-01-29 09:20:36 +0200 )edit

This just bit me - version 5.1.4.2 on Ubuntu 14. I could see the Save progress bar, but nothing was generated in the /backup directory. After a crash, I got a message that the file could not be recovered due to permissions. I haven't proven this 100%, but I believe it was caused by macros in the document. After I deleted the macros, autorecover started working again.

Joe-- gravatar imageJoe-- ( 2016-10-22 15:44:39 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-02-21 06:14:16 +0200

qubit gravatar image

Hi @ozp,

The auto recovery is set. But it does not work.

If you're still experiencing this problem with the latest release, please file a bug about this problem. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
1

answered 2012-07-19 22:43:27 +0200

manj_k gravatar image

updated 2012-07-20 00:12:22 +0200

Please check (the proper functioning of) the following paths, used by AutoRecovery information:

Tools → Options → LibreOffice → Paths →
Paths used by LibreOffice
Backups
Temporary files

Save AutoRecovery information creates temporary folders/files (sample: abc.odt):

in Backups path
abc.odt_0.odt / abc.odt_1.odt / abc.odt_0.odt, etc. (change every xx minutes)

in Temporary files path (on Windows)
folder lukvzp6.tmp · with file lukvzqv.tmp (or similar).

edit flag offensive delete link more
1

answered 2012-07-19 01:40:07 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Menu/Tools/Options/Load-Save/General/Save - Save Autorecovery information every

edit flag offensive delete link more
0

answered 2013-06-26 19:22:50 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Just happened to me... Autosave was set to 1 minute. Linux crashed (Ubuntu Unity interface), and came back and there was nothing in the backups folder, nothing to recover... (arg!!!!)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-18 23:39:06 +0200

Seen: 7,374 times

Last updated: Jun 26 '13