Ask Your Question
1

How can I unlockWriter documents to edit on another computer? [closed]

asked 2012-07-20 17:56:55 +0100

Newshawk gravatar image

updated 2015-10-17 01:17:27 +0100

Alex Kemp gravatar image

I use both a laptop and a desktop computer. Both have the latest version of LibreOffice installed and both run Windows XP Pro, SP3. However, this has been a problem from when I first started using the laptop about a year ago, so it spans multiple versions of LibreOffice.

My files are on a flash drive. When I edit files in Writer on my laptop computer it locks them so they cannot be edited on my desktop computer. I have looked everywhere I can to find out how to turn this feature off. How can I turn off the lock feature in Writer (or Office?)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 01:18:17.972771

Comments

Do you closed the files before extract the flash drive?

m.a.riosv gravatar imagem.a.riosv ( 2012-07-20 18:48:35 +0100 )edit

Yes, I close the file and click on the safe removal icon in the taskbar.

Newshawk gravatar imageNewshawk ( 2012-07-24 02:59:55 +0100 )edit

@Newshawk -- Did @manj_k's answer help you? Are you still looking for an answer here?

qubit gravatar imagequbit ( 2013-03-13 10:27:55 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2012-07-21 01:11:33 +0100

manj_k gravatar image

You might edit main.xcd [path: program_files\LibreOffice\share\registry\main.xcd]:

Modify the following default <value>true<value> ...

    <prop oor:name="UseDocumentSystemFileLocking" oor:type="xs:boolean" oor:nillable="false">
      <value>true</value>
    </prop>
    <prop oor:name="UseDocumentOOoLockFile" oor:type="xs:boolean" oor:nillable="false">
      <value>true</value>
    </prop>

image description

... to customized <value>false<value>

    <prop oor:name="UseDocumentSystemFileLocking" oor:type="xs:boolean" oor:nillable="false">
      <value>false</value>
    </prop>
    <prop oor:name="UseDocumentOOoLockFile" oor:type="xs:boolean" oor:nillable="false">
      <value>false</value>
    </prop>

image description

Save main.xcd. Backup and reset your LibreOffice user profile, restart LibreOffice.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-20 17:56:55 +0100

Seen: 1,578 times

Last updated: Jul 21 '12