Ask Your Question
0

Table of Contents option too confusing [closed]

asked 2012-07-23 00:00:41 +0200

DLH gravatar image

updated 2013-06-12 19:39:59 +0200

manj_k gravatar image

I don't know a lot about computers and am trying to create a table of contents in libre office. Have tried their help, but it's crap, and I've been unable to get it to do anything except produce the words "table of contents". Can anybody explain this in simple language? Honestly, it's like mud.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 03:41:32.580827

3 Answers

Sort by » oldest newest most voted
2

answered 2012-07-23 01:17:14 +0200

oweng gravatar image

You will need to read through ch12 of the Writer Guide v3.4 and possible ch6 and ch7 as well in order to understand how styles works, as these are the basis for generating a table of content.

edit flag offensive delete link more

Comments

Thank you so much! I finally got it to work - lots of trial and error, but now it's much easier!

DLH gravatar imageDLH ( 2012-07-25 02:48:15 +0200 )edit
0

answered 2012-07-25 02:46:13 +0200

DLH gravatar image

Okay, I finally got it to work. And thanks so much, oweng! Once I got the guide to load properly (it takes a while), those chapters were helpful (you don't need all the info in them just to make the TOC, though). However, the most helpful thing turned out to be the "apply style" button at the top left of the toolbar, next to the button that lets you select the font, and after the Styles and Formatting button). The chapter titles ALL had to have "Heading 1" applied to them (not heading, heading 2, etc) for the programme to work to create a TOC. The body text following the chapter title was at the default setting, not the Heading 1 setting. Then I opened Styles and Formatting(the one at top left that looks like four little squares with the first square yellow) and right-clicked on Heading 1 and selected Modify to make sure the "next style" was Text Body (or default, or whatever style the paragraph is in). Then I went to where I wanted to put the TOC in the doc and clicked Insert - Indexes and Tables - Table of Contents and hit OK to take the default setting. It automatically generated a grey TOC - to turn the grey off, you have to go to Tools - Options - Libreoffice - Appearance and in the area that says Text Documents, you can deselect Index and table shadings. If you know the stuff in the 3 chapters oweng suggested above pretty well, you can probably personalize this more. I was just grateful it finally worked. It also opened on my Word starter 2010 programme(which doesn't include the create TOC option)and the hyperlinks still worked. :-)

edit flag offensive delete link more
0

answered 2012-07-23 02:56:07 +0200

DLH gravatar image

updated 2012-07-25 02:51:09 +0200

The answers above were very helpful - if you know a lot of stuff about styles, you might be able to personalize this more than I did, but the basic TOC is there now, and the hyperlinks work!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-23 00:00:41 +0200

Seen: 1,834 times

Last updated: Jul 25 '12