Ask Your Question
2

File sizes when saving in .xls format [closed]

asked 2012-07-24 11:58:24 +0200

anonymous user

Anonymous

Having upgraded from 3.4 to 3.5 I find that a 30KB spreadsheet in .ods format, which would have been 90KB saved in .xls format has suddenly grown to a 9MB file. Has anyone else found the same thing? I have another spreadsheet shered with colleagues who only use MS Office - if the same thing happens with that it will be about 2GB in size and take half an hour to load.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-27 03:49:00.647362

8 Answers

Sort by » oldest newest most voted
0

answered 2012-12-23 15:38:39 +0200

qubit gravatar image

I just upgraded a machine to Ubuntu 12.04 and it's running LibreOffice 3.5.4.2, so I'll try to test again.

The 'Keswick' test file is 31.4kB, and if I open it and immediately save it out, the filesize grows (very little) to 38.9kB. If I then put a single 'x' in cell A35 and save again, the filesize creeps up to 39.1kB.

Result: As of 3.5.4.2, I'm not able to repro this bug.

edit flag offensive delete link more

Comments

Hi @Rob Cook, It looks like we can't reproduce your problem using the latest builds of LO. Could you please upgrade to 3.6 and let us know if that solves your issues? Thanks!

qubit gravatar imagequbit ( 2013-01-23 22:01:08 +0200 )edit
1

answered 2012-07-29 14:57:22 +0200

Rob Cook gravatar image

Sorry, more questions than answers. Apparently uploading files requires karma>3, which I am some way from reaching.

edit flag offensive delete link more

Comments

(one more upvote for you; and 3 is easy to get -- wait until you want to retag some questions, that takes hundreds of karma points! ;-)

qubit gravatar imagequbit ( 2012-07-29 17:56:14 +0200 )edit

Thanks. I have attached the file as requested. I have also tried sending the .xls version to my MSOffice-dependent colleague, but the email server imposes a limit of 5MB so it has been refused.

Rob Cook gravatar imageRob Cook ( 2012-08-08 10:25:40 +0200 )edit
0

answered 2012-08-14 23:52:01 +0200

I guess LO Calc 3.5 is considering the blank lines of all the spreadsheets as non blank lines. I had this problem with Excel and had to delet all unused lines after the last used line. I opened with Excel the xls file saved in Calc and did it, then the file size decreased.

edit flag offensive delete link more
0

answered 2012-12-24 13:26:27 +0200

ROSt52 gravatar image

This is not the answers but I made a test with the file provided

  1. saved the file as it opens on my desktop: size 31.5 kB
  2. added my name into a cell and saved: 31.6 kB
  3. added numbers from 1111 to 5275 with increment 1, thus 4164 4 digit figures and saved: 56.8

Hope this information helps to find the solution.

LibO 5.6.4.3 on XP/SP3

edit flag offensive delete link more
0

answered 2012-07-31 16:33:13 +0200

Rob Cook gravatar image

Here's the file.Keswick 2012 Week 3.ods

edit flag offensive delete link more
0

answered 2012-07-26 05:42:32 +0200

qubit gravatar image

To clarify: You're saying that a file you created in LO 3.4 of size 30K has turned into a 9MB file by opening and then saving in LO 3.5?

It would be very helpful if you could attach the original 30K file to this question do that we can try to reproduce your problem locally. If you can't share the original file, you could try to create a modified version of the file (or a wholly new file) that demonstrates the same bug.

edit flag offensive delete link more
0

answered 2013-03-20 19:17:42 +0200

Hendy gravatar image

I recently experienced this (assuming I understand the queston properly) and think I have an idea about what's going on. Information:

$ uname -a Linux hostname 3.8.3-2-ARCH #1 SMP PREEMPT Sun Mar 17 13:04:22 CET 2013 x86_64 GNU/Linux

$ libreoffice --version LibreOffice 4.0.1.2

I believe that for some reason, some cell in distant rows/columns gets registered as containing a value, despite being blank. When exporting to xlsx, I think Libreoffice is storing some sort of value in all columns/rows up to that distant cell. Alternatively LO is potentially storing some sort of data in all blank rows/columns instead of just leaving them absent when exporting.

I suspect this, as on a hunch I selected the first blank column of my data and did Ctrl + Shift + Right Arrow. This selects all columns up to AMJ. Then right click and choose "Delete columns."

Repeat for rows and do Ctrl + Shift + Down Arrow and delete all blank rows.

I then did "Save as..." from .ods -> .xlsx successfully.

  • Before doing this: ~20kb .ods saves as 3.4mb .xlsx
  • After deleting blank rows/columns as described above, I get a ~21kb .xlsx instead.
edit flag offensive delete link more
0

answered 2013-01-24 05:12:31 +0200

ROSt52 gravatar image

I don't have yet the solution but I downloaded the file linked with ".Keswick 2012 Week 3.ods" and saved it on my desktop and the file size is 32 KB. I can see 5tabs (Day 1-5) 1 tab Event Weekly Shop Report. All sheets look OK to me.

However, I don't know yet why the file gets so big at your PC.

I using XP/SP3 on LibO 3.6.4.3

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-24 11:58:24 +0200

Seen: 3,487 times

Last updated: Mar 20 '13