Is there a bug with empty commas for csv import? [closed]

asked 2014-11-06 17:02:57 +0200

taqmobile gravatar image

updated 2014-11-06 18:10:27 +0200

If I have a csv file with the following data

"col1","col2","col3","col4","col5","col6","col7","col8"
"x","x","x","x","x","x","x","x"

libre calc imports it fine

But If I have empty commas, it breaks. The preview for import looks ok but when it actually processes, it basically takes all following data and places it into the column before the commas. 4 of the commas are removed and the data just has the remaining commas and ALL other data in the column now.

"col1","col2","col3","col4","col5","col6","col7","col8"
"x","x",,,,,,"x"

See video: http://screencast.com/t/hALFEe1g

The video pretty much confirms the issue

I can work around it by added empty quotes "" instead of nothing. Perhaps libre calc just doesn't support empty commas the same way excel does?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2016-03-05 22:17:20.800906

Comments

I cannot reproduce the results you describe. But the guy who made the "video" should not expect sensible results having set the comma as a column delimiter and as the text delimiter as well. In his case the funny thing is what he claims to get as preview.

Lupp gravatar imageLupp ( 2014-11-06 20:25:42 +0200 )edit

I don't follow. Of course text will have commas.. they should be escaped if they are within quotes. The simple fact that the "preview" shows it correctly, but the finished data shows it wrong is proof enough of the bug.

taqmobile gravatar imagetaqmobile ( 2014-11-14 15:39:34 +0200 )edit

Did you notice that the comma was checked as 'Text delimiter' and among the column delimiters, too, in the import dialog in the video? No doublequotes visible. How to processs that?

Lupp gravatar imageLupp ( 2014-11-14 22:11:19 +0200 )edit