Ask Your Question
1

Libreoffice refuses to hide text overflow [closed]

asked 2014-11-15 08:13:50 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I read and understand the official documentation. I had easily found the setting, and followed the instructions to the letter, as well as corroborated it with several online guides.

After many hour of trying, it simply doesn't work. The setting appears to be broken. "text overflow" checkbox is merely a decoration with no actual functionality.

OS: Centos7

Version: 4.1.4.2

Build ID: 4.1.4.2-3.el7

Aka: Mcbuggypants

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 04:17:11.904370

Comments

Just to put it absolutely clear: You are missing the little red triangle (surrounded by a thin black line) hinting the existence of not displayed parts of the text content of a Calc cell in the case of a neighbour cell not accepting being used for the overflow to display or at the left or right border of all the sheet. You are also aware of the effects of invisible content and of hidden columns and of the feature not applying to vertical overflow or to rotated orientation.

Lupp gravatar imageLupp ( 2014-11-15 12:48:54 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-11-15 13:26:52 +0200

Lupp gravatar image

updated 2014-11-15 13:41:01 +0200

(For those who may take the original subject "Libreoffice {Calc} refuses to hide text overflow" litterally and may not have read and understood the complete documentation)

The option > 'Tools' > 'Options' ('Preferences') > 'LibreOffice Calc' > 'View' > 'Display' > 'Text overflow' does not afflict the overflow itself but its indication by an 'overflow marker'.

The overflow itself is unchangeable default (afaik). To anyhow prevent the overflow itself you have to use specific means:

1) Create (invisible) content for the cells potentially afflicted by the overflow. There are different ways to do so.

2) Set the 'Alignment' property 'Wrap text automatically' or 'Shrink to fit cell size' for the potential source of overflow.

3) Create a column containing any content whether visible or not in the concerned rows and hide it.

There is one strange thing I found (V4.3.3): Having wrapped content (by autmatic wrapping or by forced linebreaks) in a cell not fiitting into its display size because of too small row height you will get the overflow mark at the right side independent of the horizontal cell alignment.

edit flag offensive delete link more

Comments

I found this question still isn't answered properly when googling. The solution I found: Select the cells -> format cells -> alignment -> text alignment -> horizontal -> set to 'filled'

johan gravatar imagejohan ( 2017-10-26 12:32:58 +0200 )edit

You find a comment on this suggestion by @Mike Kaganskihere.

Lupp gravatar imageLupp ( 2017-10-26 14:43:01 +0200 )edit

Yes, this fixed my spreadsheet: The solution I found: Select the cells -> format cells -> alignment -> text alignment -> horizontal -> set to 'filled'

JAKE gravatar imageJAKE ( 2018-09-22 09:39:40 +0200 )edit

@JAKE: did you read the two comments above yours, and in specific the comment by @Mike Kaganski in the thread I linked to?
To set the alignment to Horizontal=Filled or to Wrap... or to Shrink... is a workaround at best.
A solution would require to introduce a new alignment attribute like Allow overflow with values like No and Yes or, better, No, Left side only, Right side only, Both sides.

Lupp gravatar imageLupp ( 2018-09-22 11:36:27 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-11-15 08:13:50 +0200

Seen: 8,329 times

Last updated: Nov 15 '14