Ask Your Question
0

How to skip empty cells when dragging to fill down in Calc [closed]

asked 2014-12-10 13:34:06 +0100

vcs gravatar image

In LO Calc I used to be able to select one cell containing a formula plus an empty adjacent cell underneath it, then drag to fill down and this would fill in with the formula calculations EVERY OTHER cell (i.e. taking into account that I have also selected one empty cell underneath the formula cell). After upgrading to LO 4.3.4 this doesn't seem to happen any more, but instead the formula is copied in EVERY SINGLE cell (i.e. the fact that I selected an empty cell underneath the formula cell seems to be ignored). Is there any way I can revert to the former behavior? I know I can select the formula and the empty cell underneath it, then copy and paste special with the 'skip empty cell' selected, but the dragging functionality was so much easier and would probably save me a bit of time!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-07 01:25:27.930909

Comments

I would like to suggest considering if not the "every-other-row-mode" in Calc sheet design might be a recurrent source of problems. From not too few examples presented in this forum, e.g. (and in some others) I know it sometimes is.

Lupp gravatar imageLupp ( 2014-12-10 13:49:49 +0100 )edit

Lupp thank you for your comment. Just wanted to make sure I understand your suggestion - are you referring to the layout of the data in my Calc sheet or the code in the software?

vcs gravatar imagevcs ( 2014-12-10 15:22:47 +0100 )edit

I actually am talking of you layout (as I'm guessing it). There were other questions telling me that some users tend to a sheet design where every other row is kept empty (for readability, eg.) or does contain different formulae or data of a different meaning and structure. From these cases and from some older experiences I would judge this being an extra weighty complication for maintenance, enhancements and scaling of an application containing such a sheet.

Lupp gravatar imageLupp ( 2014-12-10 19:28:52 +0100 )edit

Lupp thanks for sharing but this is not a sheet design concern, but merely about getting back a functionality that used to be there. Please comment if able to help with that!

vcs gravatar imagevcs ( 2014-12-11 01:01:50 +0100 )edit

Sorry! Hope someone else can help you. The only suggestion I can make is downgrading to a version you know working as you need it.

You may also file a bug report on https://www.libreoffice.org/bugzilla/

If you decide to do so, please also place a link to your report in this thread.

Lupp gravatar imageLupp ( 2014-12-11 13:44:42 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-12-11 14:34:01 +0100

ROSt52 gravatar image

@vcs & @Lupp - I made a test in 4.3.4.1 (XP) and can confirm the bug @vcs observed.

I regard it as a bug because 1 - When I have a cell with content "a" and beneath this cell another one with content "b", select both cells and drag down a get a sequence of a, b, a, b, a, b,... 2 - When have a cell with the formula =a1+b1 and beneath this cell another one with the formual =a1-b1, select both cells and drap down I get the sequence =a1+b1, =a2-b2, =a3+b3, = a4+b4, = a4+b5....

As for a currently possible workaround I see like @Lupp, only the possibility to downgrade. The downgrade could also be done by using a portable version of LibO using v4.2.6 or 7.

May I propose @vcs to file a bug report here: https://www.libreoffice.org/get-help/...

edit flag offensive delete link more

Comments

ROSt52 thank you for your answer! I will file the bug and revert to 4.2.7 until this is sorted.

vcs gravatar imagevcs ( 2014-12-11 17:08:30 +0100 )edit

Just a remark:: Afaik, the V4.2.7 was the first version containing the "adjust-references-on-sort-bug" that caused some confusion (and was fixed with V4.3.4). If you need 'Data' > 'Sort' for ranges cells of which are referred by formulae, you might better use an even earlier version.

I fully agree that it's a bug. I also can confirm it for all the versions I presently can test with except V3.6. Unfortunately I have no 4.2.x at hand. (Nonetheless I would try to avoid the every-other-row design.

Lupp gravatar imageLupp ( 2014-12-11 17:22:16 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-12-10 13:34:06 +0100

Seen: 664 times

Last updated: Dec 11 '14