Ask Your Question
0

Default Language won't save [closed]

asked 2014-12-14 01:11:01 +0200

Warwick gravatar image

updated 2016-03-06 14:02:55 +0200

Alex Kemp gravatar image
  1. Writer
  2. Version: 4.2.7.2 / Build ID: 420m0(Build:2)
  3. Locale setting: New Zealand

  4. Ubuntu 14.04

  5. New Zealand

What I want to do is have each new document open with UK as the default language because NZ has no dictionary yet for spellcheck.

What I did is open a new document, create my template, save the template as default. But even when I go into language settings and change the 'default language for documents' to UK, even though it changes current document, it reverts back to NZ for new documents. This still happens even after I have changed the 'default language for documents' to Uk and save that version as the template. I still have new docs opening with NZ as the language.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 14:03:15.461536

1 Answer

Sort by » oldest newest most voted
0

answered 2014-12-14 05:39:50 +0200

ROSt52 gravatar image

updated 2014-12-14 05:43:08 +0200

@Warwick - Good description on what you did but the key information is missing. Key information is how you set the UK English default languages and how you saved the template and how you set it as your default template.

I made a test im my LibO4.3.4.1 on XP, Default language is English US, one of the other installed languages is German, which I used for the test.

1 - Open a new Writer document
2 - Typed a sentence in German so that LibO could recognize that this is German
3 - Tools > Language > For all text > German - All words were indicated as correct except for the few I mistyped on purpose. I used right click to get the correct spelling. Thus, the language setting are correct for this document
4 - File > Save as template using a new name for this template but I did not set this template as my default template.

If I want to use this German language template as my default template, I need to flag it as my default template. Otherwise my previous default template opens automatically whenever I open a new Writer file.

For setting your template as your default template you can do:
File > Template Menu > Save as template (even if you don't want to save the template again) > select the template you want to use your default template > click Set as default (in the top of the window)

I recommend you to also look into the guides, which you can download free of charge from: https://wiki.documentfoundation.org/D...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-12-14 01:11:01 +0200

Seen: 938 times

Last updated: Dec 14 '14