Ask Your Question
0

PDF import

asked 2014-12-16 09:47:24 +0200

alle_meije gravatar image

On LibreOffice 3.5.4.2 (default for Debian Wheezy) importing PDFs is not a core feature, so I installed the package libreoffice-pdfimport to read a PDF file into Writer.

What I get with 'File' -> 'Open' -> 'test.pdf' is still the ASCII filter dialog and the PDF just opens as an ASCII file:

%PDF-1.4
%�쏢
5 0 obj
<</Length 6 0 R/Filter /FlateDecode>>
stream
x��\[o#Ǖ~ׯ��Ɇ�Wu�#��

etc...

Converting the file to PostScript and back to PDF using pdf2ps and ps2pdf makes no difference. Is there a trick to importing PDFs into Writer that I am not using?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-03-01 08:24:57 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi - The pdf import extension allows to open a pdf in Writer only if it is an hybrid pdf.

See our Wiki FAQ

If it is not a hybrid it could be only opened in Draw. That may be the problem?

edit flag offensive delete link more
0

answered 2015-03-01 07:45:55 +0200

meolar gravatar image

I am not sure if my experience will help with LibreOffice 3.5.4.2. I'm using version 4.4. However, the last version I used (4.2, I think) worked the same way as what I have now. So with that caveat, I'll try to address your question.

I have not found a good way to do get pdf files into Writer and keep the formatting. I have used Calibre to convert a pdf to a text file. It did not give me all the bizarre characters that showed in your example.

To use this approach, you'll need to have Calibre installed.

If you have Calibre open:

  1. Click “Add books” and then “Add books from a single directory”
  2. Browse to the pdf file, click it, and then click the "Open" button
  3. Back in the main window of Calibre click the pdf file
  4. Click the “Convert books” button at the top and choose "Convert individually"
  5. In the upper right corner where it says “Output format,” change it to “TXT”
  6. Click the “OK” button at the bottom right
  7. In the main window of Calibre on the right side where it says “Path” click on “Click to open”
  8. Open the .txt version of the file

Unfortunately, all you have is the text with this method. It is possible to open a pdf and get the pictures along with the formatting and text in Draw, but the text does not flow from one line to the next.

It isn't an elegant solution, but perhaps a combination of the above will get you what you want.

edit flag offensive delete link more

Comments

This worked brilliantly for me with latest version of Calibre, but of course, it's file / filetype dependent, I guess. Thanks for posting it.

OzKiwi gravatar imageOzKiwi ( 2015-10-04 10:42:51 +0200 )edit

You're welcome. I'm glad it helped.

meolar gravatar imagemeolar ( 2016-04-04 00:59:59 +0200 )edit

If your question is answered, please click on the check mark by the answer that helped to mark it as answered. Thanks!

meolar gravatar imagemeolar ( 2016-11-12 19:33:20 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-12-16 09:47:24 +0200

Seen: 39,266 times

Last updated: Mar 01 '15