Ask Your Question
0

Rows not splitted into colums importing a CSV file

asked 2014-12-31 13:55:28 +0100

VincentD gravatar image

I'm trying to import a CSV file into Calc seperated by semicolons, but even though I check semicolons as a separator during import, all lines get imported with a single column. If after import I select all lines and do Data > Text to Columns, the first few hundred rows get splitted, but after that nothing. Am I doing something wrong?

edit retag flag offensive close merge delete

Comments

without the .csv-file in question nobody is able to answer that!

karolus gravatar imagekarolus ( 2014-12-31 14:00:29 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-12-31 14:17:01 +0100

ROSt52 gravatar image

updated 2014-12-31 14:18:35 +0100

@karolus is right, without the file it is difficult to give you a precise answer.

Just some hints:
Check character set and language
A CSV file can have different separators. Try all possibilities and see how the columns would appear.
Look also to the options and test them.

Additionally I recommend to have a look at the free guides which you can download from http://www.libreoffice.org/get-help/d...

edit flag offensive delete link more
0

answered 2015-01-01 23:56:24 +0100

The csv format is not well defined and never has been. The problem is that commas just have to be allowed within an entry. People "solve" that problem by putting comma containing entries in quotes but then it's hard to include quotes in an entry. Worse, some csv files arrive with every entry quoted, needed or not. There is no decent way to figure it all out.

In Excel I find that a conversion to tab separated items with no tabs allowed works more reliably.

I convert with a 2 kB perl script which resides in /bin/ of my home directory but it's still not perfect. Ask and I'll be happy to make it available.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-12-31 13:55:28 +0100

Seen: 206 times

Last updated: Jan 01 '15