Ask Your Question
0

Advice re: using a ‘deprecated’ Mac OS X version with current LO (v. 4.3.5)

asked 2014-12-31 16:05:54 +0200

mkraft gravatar image

The v.4.3.5 Release Notes documentation includes the advice “Mac OSX 32 bits build and version 10.6 and 10.7 are deprecated.” (Platform Compatibility section)

I would like to put LibreOffice on an older model MacBook that doesn’t support OS X versions more recent than 10.6.8.

What does the term “deprecated” imply? That LO 4.3.5 will work to some extent but problems will be experienced?

Should I instead download an earlier LO version that will be better suited to the older OS X version I have on that computer?

Thanks.


re: LO 4.3.5 (English language) / particularly Writer Mac OS X 10.6.8 (Snow Leopard)

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-12-31 20:05:18 +0200

mkraft gravatar image

> Mac OS X 10.6 (Snow Leopard) or higher

Thanks, looks like I'll be okay (until May 2015).

But then why the 'deprecated' label I referred to on https://wiki.documentfoundation.org/ReleaseNotes/4.3#Most_Annoying_Bugs --?

(very bottom of webpage under 'Platform Compatibility')

edit flag offensive delete link more

Comments

see EDIT in my answer

ROSt52 gravatar imageROSt52 ( 2015-01-01 08:22:25 +0200 )edit
0

answered 2014-12-31 16:45:18 +0200

ROSt52 gravatar image

updated 2015-01-01 08:26:01 +0200

This is what is stated here: http://www.libreoffice.org/get-help/s...

Apple - Mac OS X

The software and hardware prerequisites for installing on a Apple Mac OS X computer are as follows:

Mac OS X 10.6 (Snow Leopard) or higher;
Intel processor;
512 Mb RAM;
Up to 800 Mb available hard disk space;
1024x768 graphic device with 256 colors (higher resolution recommended).

It is a recommended best practice to back-up your system and data before you remove or install software.

Notes:

For certain features of the software - but not most - Java is required. Java is notably required for Base.
Detailed information about Gatekeeper and OS version support may be found on the TDF Wiki.
The next release series (4.4) will require OS X 10.8+; Support for OS X 10.6/10.7 will end when LibreOffice 4.3 is retired on May 27, 2015.

The last 2 lines maybe the important information for you.

I installed recently LibO 4.3.4 on a MacBookPro and consider to upgrade to 4.3.5 ASAP.

EDIT
You can keep using the LibO 4.3 version as long as you stick with your OS. 4.3 is a pretty good version.

As for the statement

Mac OSX 32 bits build and version 10.6 and 10.7 are deprecated.

I feel this could be a mistake in the 4.3 release notes. At least until now I did not observe a problem with 4.3.4 with OS 10.6

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-12-31 16:05:54 +0200

Seen: 3,828 times

Last updated: Jan 01 '15