Ask Your Question
0

spelling checker not working anymore

asked 2015-01-03 21:02:23 +0200

JoeAlders gravatar image

updated 2015-09-27 18:38:15 +0200

Alex Kemp gravatar image

Since installing LibreOffice 4.2.8.2 my spelling checker (Eng UK) does not work anymore despite setting options ect. correct. Did install also the GB help pack. How can I restore this? I am using Windows 7 64 bit as O.S English language. Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-01-04 06:27:48 +0200

ROSt52 gravatar image

updated 2015-01-05 13:42:56 +0200

Please check it the extension is still installed: Tools > Extension Manger.

If not install it again.

EDIT

A new installation is also what I would do/recommend. However, I would remove also the LibreOffice Application folder by renaming it.

After you installed LibO remove/rename the LibreOffice Application folder. In W7 the Application Folder should be somewhere under your user name. Go into it and you find a folder LibreOffice. Renaming it is enough

Now reboot your machine and start a new application.

I am not sure if W7 still used the Sytem Restore like XP. If so, before starting the new installation, you could possibly also make restore to a system point prior to the installation of the 4.2.8 version. I typically make a new restore point before I upgrade LibO on my XP machine.

After the installations check the spell checker. If all works fine you can replace folder by folder the new folder in /Application Data / Libre Office by the old ones which you save be renaming the folder containing all. By doing so you get all your customization back. However, you better test the spell checker after each replacement to see in which folder the problem was.

,

Before I install a new version of LibreOffice I always copy the old package and rename that as LibreOfice4_old.

I don't understand what this package is. From where do you take this package, what is its content, and where do you save it?

edit flag offensive delete link more

Comments

Before I install a new version of LibreOffice I make a copy of the old one and rename that copy. In this case 'LibreOffice4_old'. I called this a 'package'. Then I install the new version and, if I understand this correctly, it overrides the installed version (=LibreOffice4).What I did now is a reinstall and this solved this strange problem.The spelling checker works fine now. The only thing what I always do is to hack the 'startcenter.ui' file to get rid of that recent docs display 'feature'.

JoeAlders gravatar imageJoeAlders ( 2015-01-06 15:34:00 +0200 )edit

@JoeAlders - Which folders/files to you copy and rename?

ROSt52 gravatar imageROSt52 ( 2015-01-08 12:00:02 +0200 )edit
0

answered 2015-01-04 12:41:06 +0200

JoeAlders gravatar image

ROSt52, I checked what you advised and could not find anything wrong with the Extension Manager settings. What I find strange is that after a spelling and grammar check, when I make a deliberate misspelling, there is always a 'the spell check is complete' window with no comments. So there is a spelling check but LibreOffice cannot find anything wrong with the text how ever the mistakes I made. Before I install a new version of LibreOffice I always copy the old package and rename that as LibreOfice4_old. I pointed the LibreOffice desktop short cut to the .exe file in that old package and now the spelling checker works fine. I think the best thing to do is to uninstall and re-install that the new version, see if this helps.

edit flag offensive delete link more

Comments

See EDIT in my previous answer.

ROSt52 gravatar imageROSt52 ( 2015-01-05 13:27:44 +0200 )edit

Before I install a new version of LibreOffice I make a copy of the old one and rename that copy. In this case 'LibreOffice4_old'. I called this a 'package'. Then I install the new version and, if I understand this correctly, it overrides the installed version (=LibreOffice4).What I did now is a reinstall and this solved this strange problem.The spelling checker works fine now. The only thing what I always do is to hack the 'startcenter.ui' file to get rid of that recent docs display 'feature'.

JoeAlders gravatar imageJoeAlders ( 2015-01-07 08:55:49 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-03 21:02:23 +0200

Seen: 2,967 times

Last updated: Jan 05 '15