Ask Your Question
0

starting with LibO from Launchpad.net

asked 2015-01-04 11:05:29 +0100

ROSt52 gravatar image

updated 2015-08-29 10:29:49 +0100

Alex Kemp gravatar image

I am a newbie to Linux with all the many questions newbies have.

I setting up my next machine with kubuntu 14.04 LTS. The current version of Libo in the repository is 4.7.2.2. {Meant: 4.2.7.2? - edited by Lupp} I intent to upgrade to 4.3.5.2 from Launchpad.net

The installation notes in the Installation Wiki states that LibO must be completely uninstalled before upgrading.

Questions:
1 - Is the only necessary to completely uninstall LibO when downloading files from LibO and installing without a PPA or is it also needed for installations from the Launchpad.net PPA?
2 - After I installed for the first time from Launchpad.net PPA and want to upgrade to 4.3.6 etc do I need to completely uninstall each time or is it possible to make an upgrade without a complete uninstallation?

edit retag flag offensive close merge delete

Comments

@Lupp - Thanks for correcting the version number typo. ---- What features will we have in 4.7???

ROSt52 gravatar imageROSt52 ( 2015-01-05 01:45:02 +0100 )edit

@ROSt52

The 4.7.x series will come in Juli 2016

;-)

karolus gravatar imagekarolus ( 2015-01-05 09:04:45 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-01-04 12:14:31 +0100

karolus gravatar image

updated 2015-01-04 19:15:44 +0100

I'm on LinuxMint17 ( Debian-based as Ubuntu,Kubuntu and others)
and i have beside the LO wich came from Mint-repos also LO4.2 and LO4.3 directly downloaded from libreoffice-downlod and installed via sudo dpkg -i *deb
They are all run without any problem ( but not at the same time, because they share the same user-configuration )
The 4th. Office i've installed is AOO4.1 which can run at the same time as one of the others also without any problems.

I hope that answers your questions!

Additional:
The LO from Mint installs to /usr/lib/libreoffice/
The LO4.2.x-versions from LO installs to /opt/libreoffice4.2/
the LO4.3.x-versions from LO installs to /opt/libreoffice4.3/
AOO4.x goes actually to /opt/openoffice4/

edit flag offensive delete link more

Comments

@karolus - Thanks for your explanations. More than 1 version installed (not running) is an interesting feature.

If you have more than 1 version installed, it means that you did not uninstall an installed version before installing the next version.

Do you know if this is also possible if the installation is made from the LibO project at Launchpad?

ROSt52 gravatar imageROSt52 ( 2015-01-04 17:16:01 +0100 )edit

I have currently no experience with Launchpad - but my guess is, it installs to the same place as the "normal" LO from kubuntu - so the former LOversion will be simply replaced on updates?!

karolus gravatar imagekarolus ( 2015-01-04 18:56:05 +0100 )edit

@karolus - Thanks for the additional information. Got now a glimpse on how more than 1 version is installed on a Linux system.Very helpful!!!

When you upgrade from let's say 4.3.5 to 4.3.6. Do you uninstall 4.3.5 first and if so how?

ROSt52 gravatar imageROSt52 ( 2015-01-05 01:42:29 +0100 )edit

No I don't have to unistall anything in that case, because the contents in /opt/libreoffice4.3/ are replaced by the new contents

karolus gravatar imagekarolus ( 2015-01-05 08:46:10 +0100 )edit

@karolus - A last question please - Let's say I have 4.2 and 4.3 installed and don' t need 4.2 any more. How do I uninstall the 4.2 version without effecting the 4.3 version?

The uninstallation guideline ( https://wiki.documentfoundation.org/I... ) appears to me as to uninstall all from an Linux PC.

ROSt52 gravatar imageROSt52 ( 2015-01-06 02:01:52 +0100 )edit

So how you installed 4.2 ?

rautamiekka gravatar imagerautamiekka ( 2015-01-06 02:04:57 +0100 )edit

@ROSt52:
sudo rm -rf /opt/libreoffice4.2/

karolus gravatar imagekarolus ( 2015-01-06 08:04:02 +0100 )edit

@karolus - Thanks for your reply. I will now tackle that task of installing LibO using the deb. I might get back to you if I run into troubles with my multi-language installations. Need English (main) GUI and Japanese (sub) GUI and dictionaries for English, German, Dutch (Japanese is not available).

ROSt52 gravatar imageROSt52 ( 2015-01-06 11:18:25 +0100 )edit

@rautamiekka - The 4.2 version comes with the kubuntu package. ---- My idea is to keep this installation alive and use it always as the "still" version, whereas I will install the "fresh" version myself using the deb-file from the LibO download. For me this configuration appears ideal. A stable "still"l version with automated updates the and a "resh" version, and I can choose which one to use. Although a good tool for working at AskLibO. @karolus ' configuration gave me this idea.

ROSt52 gravatar imageROSt52 ( 2015-01-06 17:31:52 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-04 11:05:29 +0100

Seen: 430 times

Last updated: Jan 04 '15