Ask Your Question
0

Poor performance when opening menu items

asked 2015-01-04 23:58:19 +0200

DeathAndPain gravatar image

Hello everyone,

When performance is mentioned related to LibreOffice, it is usually about opening documents and memory settings. I have no problem with that, but when I open simple and frequently-used menu items in writer like "Format -> character", then it lasts about a second until the sub-window opens?! Iirc this problem has existed since version 4.2 (including 4.3). Is there a solution?

My system performance is certainly not the reason (Core i5-4670, 16 GB RAM, SSD).

Thanks for any suggestions.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-01-05 00:53:44 +0200

ROSt52 gravatar image

I recently had to reset my user profil and observed that the start up of LibO became much faster. Therefore, I would first try to reset the user profile: For details please refer to: https://wiki.documentfoundation.org/U...

Should this not help, Please inform in more details especially which OS are you using.

edit flag offensive delete link more
0

answered 2015-01-08 01:06:40 +0200

DeathAndPain gravatar image

I tried resetting my user profile (by renaming its folder so that a new one was created), but it had no impact upon the problem. Tbh this does not really surprise me, because I do not really see this as a performance issue that could be fixed by some sort of profile cleanup. An office program like LibreOffice usually runs in a performant manner on systems with a fraction of the performance on my machine, so my computer should easily be able to compensate for any profile inefficiencies (which is also why LibreOffice itself starts up lightning-fast even though I did not install the pre-caching functionality (I dislike programs loading part of themselves into memory on bootup just in case they will be used; imagine if every program did that).

This is the weird thing: Picking such a simple menu entry lasts equal or longer than starting up the whole LibreOffice without having cached anything up front! And that is why I consider this more as a bug than as a regular performance issue.

The delay does not apply to every menu item. Primarily items in the Format-menu (character, paragraph, page) are affected.

My system:

Windows 7 x64 SP1, no virus scanner (but also no infection, trust me on that one), latest patches on everything, Microsoft .NET framework 4.5.2, Java 7 Update 72 (but I believe to have disabled anything in LibreOffice that would use Java)

Relevant hardware specs are in the original text above.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-04 23:58:19 +0200

Seen: 326 times

Last updated: Jan 08 '15