Ask Your Question
0

How to prevent hyperlink text color changes

asked 2015-01-05 06:20:13 +0200

tenntexj gravatar image

I want to prevent my internal document hyperlinks text from turning blue with the underlining. I got the writer odt document to display the hyperlink text with black color and no underlining. The hyperlink functions but is not marked with a font color change and underlining. However when I export to pdf, the resulting pdf file turns the hyperlink text from black to blue, but it does not add the underlining. Is there any way I can get the pdf export function to retain the black hyperlink text color I have in the writer odt document?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2020-06-26 01:35:27 +0200

guanolto gravatar image

updated 2020-06-26 01:44:39 +0200

This fix doesn't work any more in LO v6.4, because it no longer uses any style called "Internet Link." Whenever I try to change the color of part of a heading that is a web address, LO refuses to obey my color change. Also, I was not able to find the relevant Options setting now.

Okay, let me correct that: It does still work: I pressed F11, and then I found that Character Format icon. Once I found that icon and clicked on it, the Internet Link style was listed and I could modify it. (But there is no such thing now as Options > LibreOffice > Appearance.)

edit flag offensive delete link more

Comments

It is there as Options > LibreOffice > Application Colours . I have Unvisited and Visited links unticked anyway and can't remember if I did that, probably a long time ago. Right click Character style Internet Link, select Modify and change colour to black and underline to (Without), OK out. Export to PDF and black hyperlinks are in the pdf.

LO 6.4.4.2, Windows 10 Pro 2004

Earnest Al gravatar imageEarnest Al ( 2020-06-26 05:33:35 +0200 )edit

@guanolto: contrary to other suites, styles are ubiquitous in Writer: paragraph, character, frame, page, list. Since an hyperlink is only part of a paragraph, it can't be controlled by a paragraph style otherwise the full paragraph would be formatted differently. Therefore, Internet Link can only be a character style, as is Visited Internet Link.

Read about styles in Writer Guide and get used to character styles instead of direct formatting.

ajlittoz gravatar imageajlittoz ( 2020-06-26 09:49:57 +0200 )edit

So there are different kinds of styles in LO. Okay, thanks for pointing this out. Good to know.

guanolto gravatar imageguanolto ( 2020-06-26 20:17:55 +0200 )edit
0

answered 2015-01-05 11:17:17 +0200

ROSt52 gravatar image

When you convert/print a Writer document to a pdf-file, the pdf-writer/exporter interpretes the incorporate link as a link and changes the color. If you don't want to see that the link is a link in your pdf-file, you must look into the pdf-writer/exporter application.

As you don't want to see that the link is a link, there could be another possibility. You paste the link as unformatted text in Writer and than the link is gone and the pdf-writer/exporter doesn't change the color and underlines the link.

edit flag offensive delete link more
0

answered 2015-01-07 06:23:32 +0200

tenntexj gravatar image

updated 2015-01-31 05:46:00 +0200

Since my last edit here, I added to my standard document template the following:

Changed blue with underling to black without underlining in both the Internet Link character style and the Visited Internet Link character style.

While keeping black selected in checked boxes for unvisited links and visited links in Tools>Options>LibreOffice>Appearance

Using that template with the above Appearance settings I have created about ten documents full of endnotes with no reappearance of blue text or underlining in my Writer document or my exported pdf hyperlinks.

I now have some measure of confidence that this problem will not pop up again.

============================================================================================= Since my last edit of this answer I have encountered situations with documents where what I thought was a reliable solution did not work.

In addition to changing the internet link character style from blue and underling to black without underlining, I have also found that making the following selections under Tools may be ncessary.

Tools>Options>LibreOffice>Appearance check unvisited links - select black check visited links - select black

I have had some documents on which doing both of these things did not work.

The most dissapointing aspect of this situation is the inconsistency in the way the program responds to these settings. What works on one document may not work the next time on another document.

There is still something going on here that I do not understand. Simply formatting hyperlinks in a word processing program and getting that formatting exported unchanged into a pdf should not be such a problem. But it is for some reason.

============================================================================================ New updated answer:

I think I finally found the correct way to do this reliably.

To change the formatting of internal document hyperlinks such as internal document links to internal document bookmarks, and have that changed formatting be carried over into exported pdf documents made using the writer export to pdf function, you do the following. Open the styles and formatting window by clicking the first icon on the left on the Formatting toolbar at the top of the screen (This is the round pink one with the white open ended wrench symbol.), or hit F11, or from the Menu bar at the top of the screen choose Format>Styles and Formatting. Click the character styles icon, which is the second icon from the left at the top of the Styles and Formatting Window and select the character style named "Internet Link". Right click and select "Modify". Select the Font effect tab and change the Font color and Underlining settings. Save the document and then export it to pdf by choosing from the menu bar File>Export to pdf. This has worked fine for my documents with internal hyperlinks to bookmarks. So far, when I do it this way I get the same hyperlink formatting in the resulting pdf document as I have in the Writer document, and it is quick and easy. One reason this was not obvious to me earlier is that the styles and formatting window ... (more)

edit flag offensive delete link more

Comments

Congratulations!

ROSt52 gravatar imageROSt52 ( 2015-01-23 02:05:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-05 06:20:13 +0200

Seen: 8,699 times

Last updated: Jun 26