Ask Your Question

How do I keep formulas from changing automatically?

asked 2015-01-07 17:56:29 +0200

Marsha1981 gravatar image

So I typed this into a cell: =$B$8, which was wrong. I meant to type =$C$8.

So I clicked on the cell, positioned my cursor in front of the B, deleted the B, and then typed C and hit enter. The only problem is, something automatically changed the C to COUNTBLANK() and left me in the formula bar, rather than entering $C$8 as I wanted.

How do I prevent this change from occurring, so that when I enter the letter C I get a letter C, and not a function name?


edit retag flag offensive close merge delete


Sometimes a bit annoying, the only way I know is move the cursor to avoid the substitution, a good place after $ sign.

m.a.riosv gravatar imagem.a.riosv ( 2015-01-08 04:28:21 +0200 )edit

That works, but when you are a touch typist you may not be looking at the screen to know that the expected action did not occur. I'll just have to keep this "feature" in mind and keep my eye on things.

Marsha1981 gravatar imageMarsha1981 ( 2015-01-08 15:07:41 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-01-08 09:00:37 +0200

ROSt52 gravatar image

I think you found a bug. I made a test in normal installation on XP and 4.3.3 portable and 4.2.6 portable

In 4,2,6 portabel changing of a character like you B to C does not evoke any function to pop up.

In both 4.3 version I observe the same annoying bug.

May I propose to file a bug report here:

It would be nice if you could place the bug number here for other to comments.

In the meantime it is the best to follow @mariosv 's advice as a workaround.

edit flag offensive delete link more


In my case this is version on Debian Stable. Is that still worth filing a bug report on?

Marsha1981 gravatar imageMarsha1981 ( 2015-01-08 15:05:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2015-01-07 17:56:29 +0200

Seen: 115 times

Last updated: Jan 08 '15